Timezone information lost when reading ics file, all times converted to floating

RESOLVED FIXED in 2.6

Status

Calendar
ICAL.js Integration
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({dataloss, dogfood})

Lightning 2.5
dataloss, dogfood

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 749426 [details]
testcase

When opening a calendar all timezone information is lost. Times are converted to floating.

STR:
1. Set calendar.icaljs to true, restart Thunderbird
2. Use menu File > Open > Calendar File to subscribe to a local ics calendar file
3. Select an event an inspect its timezone, e.g. in the Event Dialog

Error:
Event times are shown as floating instead of the original timezone.
(Assignee)

Comment 1

5 years ago
Created attachment 751464 [details] [diff] [review]
Fix - v1

This takes care. One issue was that the ical.js timezone service didn't have any timezones, the other was the referenced timezone methods I didn't implement.

I'm not quite happy with the referenced timezones implementation, but its almost like the libical version and James has plans to rewrite some of the timezone bits of ical.js. Therefore it doesn't make sense to integrate timezone refcounting into ical.js right now.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #751464 - Flags: review?(matthew.mecca)
(Assignee)

Comment 2

5 years ago
Created attachment 751476 [details] [diff] [review]
Fix - v2

Fixes an error with recurring events
Attachment #751464 - Attachment is obsolete: true
Attachment #751464 - Flags: review?(matthew.mecca)
Attachment #751476 - Flags: review?(matthew.mecca)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 871211
Comment on attachment 751476 [details] [diff] [review]
Fix - v2

r=mmecca
Attachment #751476 - Flags: review?(matthew.mecca) → review+
(Assignee)

Comment 5

5 years ago
Pushed to comm-central changeset 1f614bd1e4b3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.6
You need to log in before you can comment on or make changes to this bug.