Closed Bug 87232 Opened 19 years ago Closed 19 years ago

Blank cells in table do not display correct background color

Categories

(Core :: Layout: Tables, defect)

x86
Windows 98
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 4510

People

(Reporter: csherlock, Assigned: karnaze)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

Any blank cells in a table that have a background colour set in the <tr> tag
will not display the correct background colour. 

Reproducible: Always
Steps to Reproduce:
Use the following page to see what happens:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

<HTML>

<HEAD>

   <TITLE>Table test web page</TITLE>

</HEAD>

<BODY>

<TABLE width="100%" border="1">
   <TBODY>
      <TR vAlign="top" bgColor="#b3b3d1">
         <TD width="200">   
         </TD>
         <TD>
            &nbsp;
         </TD>
         <TD align="left" width="400">
            Test cell
         </TD>
      </TR>
   </TBODY>
</TABLE>

</BODY>
</HTML>

The first cell does not display the background colour. Now try the following markup:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

<HTML>

<HEAD>

   <TITLE>Table test web page</TITLE>

</HEAD>

<BODY>

<TABLE width="100%" border="1">
   <TBODY>
      <TR vAlign="top" bgColor="#b3b3d1">
         <TD width="200">   
            &nbsp; <!-- added space -->
         </TD>
         <TD>
            &nbsp;
         </TD>
         <TD align="left" width="400">
            Test cell
         </TD>
      </TR>
   </TBODY>
</TABLE>

</BODY>
</HTML>

And the cell displays the background colour correctly. 

Actual Results:  Doesn't fill in the cell with the correct background colour.

Expected Results:  Mozilla should have filled in the cell with the correct
background colour.
This only happens in quirks mode.  Change the HTML version from 4.0 to 4.01 to
see strict mode layout.  In quirks we act just like NS 4.x here, in strict we
follow the spec.

See bug 46268 for the discussion of why we have this quirk for table rows.

Marking duplicate of "table element backgrounds not working correctly" which is
aiming to change the quirk behavior.

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.