If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

controller.restartApplication() gives "IO Completion Port unexpectedly closed" error

RESOLVED DUPLICATE of bug 865690

Status

Testing Graveyard
Mozmill
RESOLVED DUPLICATE of bug 865690
4 years ago
a year ago

People

(Reporter: Andrei Eftimie, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
mozmill 2.0 on windows give the following error:
"IO Completion Port unexpectedly closed"
when using
> controller.restartApplication()

Will have a testcase shortly.
(Reporter)

Comment 1

4 years ago
Created attachment 749728 [details]
testcase

This shows the error reported (but no disconnect).

Trying to see if this actually leads to a Disconnect Error and if so what factors trigger it.
Attachment #749728 - Attachment mime type: text/x-patch → text/plain
Sounds like NSPR is involved here. So for which of those restartApplication() calls does it happen? For all of them?
Whiteboard: [mozmill-2.0?]

Updated

4 years ago
Whiteboard: [mozmill-2.0?] → [mozmill-2.0?][sprint2013-34]

Comment 3

4 years ago
(In reply to Andrei Eftimie from comment #0)
> mozmill 2.0 on windows give the following error:
> "IO Completion Port unexpectedly closed"
> when using
> > controller.restartApplication()
> 
> Will have a testcase shortly.
The underlying mozprocess code is printing that error[1], which isn't really an error if we shutdown the application when the underlying code didn't expect it. So in other words, this might be expected when doing restartApplication.

[1] https://github.com/mozilla/mozbase/blob/master/mozprocess/mozprocess/processhandler.py#L323
Actually this is a dupe of bug 865690.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: [mozmill-2.0?][sprint2013-34] → [sprint2013-34]
Duplicate of bug: 865690

Updated

4 years ago
Whiteboard: [sprint2013-34]
(Assignee)

Updated

a year ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.