Closed Bug 872630 Opened 8 years ago Closed 3 years ago

input type date content not in locale format

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: community, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0 Iceweasel/16.0.2
Build ID: 20121026194158

Steps to reproduce:

general.useragent.locale is "es-ES"

We're using <input type="date"> for date input.


Actual results:

After choosing a date in the correctly localized picker, the date showed has ISO format.


Expected results:

We expect it to be localized too.
OS: Linux → Android
Hardware: x86_64 → ARM
Might need bug 724529 fixed as well.
Blocks: 446510
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Firefox 21 → Trunk
This might depend on bug 773205.
Depends on: 773205
(In reply to Mounir Lamouri (:mounir) from comment #3)
> This might depend on bug 773205.

Rather Bug 825294, IMHO.
Depends on: 825294
No longer depends on: 773205
Duplicate of this bug: 1297327
(In reply to Chris Barnes from comment #6)
> Still the same problem on Mozilla/5.0 (Android 7.0; Mobile; rv:57.0)
> Gecko/57.0 Firefox/57.0

Could you test this on the latest Firefox Nightly?
Flags: needinfo?(chris)
Also, current formatted text depends on UI locale. So even if changing your UI locale from settings, you can change formatted text in textbox of date.   If you still has issue on the latest Nightly, please add completely reproduce step and screen shot.
It's working correctly for en-GB in nightly build Mozilla/5.0 (Android 7.0; Mobile; rv:59.0) Gecko/59.0 Firefox/59.0
Thank you
Flags: needinfo?(chris)
Thanks.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.