OpenSearch is not enabled

VERIFIED FIXED in 2013-06-06

Status

Marketplace
Search
P4
enhancement
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: GeekShadow, Assigned: mat)

Tracking

2013-06-06
Points:
---

Details

(Whiteboard: p=2)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0 (Beta/Release)
Build ID: 20130409194949

Steps to reproduce:

Looking for OpenSearch provider when going to https://marketplace.firefox.com


Actual results:

There is no OpenSearch provider available.


Expected results:

OpenSearch should be available so people can use the search feature of their browser. Plus OpenSearch is available on Zamboni
Severity: normal → enhancement
Priority: -- → P4
Whiteboard: p=2
https://developer.mozilla.org/en-US/docs/Creating_OpenSearch_plugins_for_Firefox
(Assignee)

Updated

4 years ago
Assignee: nobody → mpillard
(Assignee)

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

4 years ago
Pull Request up at https://github.com/mozilla/zamboni/pull/777
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2013-06-06
(Assignee)

Comment 3

4 years ago
https://github.com/mozilla/zamboni/commit/d260ffcf87ebb8153a0a9187179cde980df45039

Opensearch is now available on marketplace-dev. The entry for "Firefox Marketplace" should appear in the search provider selection dropdown of the browser when navigating anywhere in the Marketplace.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 4

4 years ago
Can you please add some exact STRs for this bug in order to verify it ?
(Assignee)

Comment 5

4 years ago
For Firefox (no idea how to configure search engines in Chrome):
- Navigate to the Marketplace homepage
- Click on the icon on the left side of Firefox's search box
- You should see a 'Add "Firefox Marketplace"' entry
- Add it
- Verify that when the 'Firefox Marketplace' item is chosen in the search box, typing a new query correctly takes you to the Marketplace search with that query.

Also do the first step the first step on the Marketplace Developers homepage to make sure we offer the search engine in both locations.

Thanks.

Comment 6

4 years ago
I followed your step , but the problem is that a new query will display the search results in the old Marketplace design instead of Fireplace : http://screencast.com/t/wEYh9eo5k

I will reopen this bug , but if I did something wrong , explain me and close again if needed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

4 years ago
Good catch, looking into that.
(Assignee)

Comment 8

4 years ago
Should be fixed now.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 9

4 years ago
Verified as fixed : http://screencast.com/t/JCuQQzcaQn
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.