Unable to setup sync from the Settings app on the first Firefox app(branch) installed if both Aurora and Nightly are installed

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
5 years ago
11 months ago

People

(Reporter: AdrianT, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox21 affected, firefox22 affected, firefox23 affected, firefox24 affected)

Details

(Reporter)

Description

5 years ago
Aurora 23.0a2 2013-05-15/ Nightly 24.0a1 2013-05-15
HTC Desire Z (Android 2.3.3) / Samsung Galaxy S2 (Android 4.0.3)

Steps to reproduce:
1) Install first Aurora and then Nightly on the device
2) Go to Settings->Accounts & sync and try to add an Aurora sync account

Expected results:
The user can choose the Firefox Account he can setup

Actual results:
The account is automatically set up as a Nightly sync account and the user manually has to add Aurora to the sync account
The account is set up for the latest of the 2 branches installed

Notes:
The same is true for Firefox Mobile and Firefox Mobile Beta

Updated

5 years ago
Component: General → Android Sync
Product: Firefox for Android → Android Background Services
Version: Trunk → unspecified
I have a sneaking suspicion that this isn't easy to fix; honestly, it's a miracle that it can work at all.
Priority: -- → P3
Can we get "fennec-tracking" added for "Android Background Services"?

Also, I would '-' this bug.
(In reply to Adrian Tamas from comment #0)
> Aurora 23.0a2 2013-05-15/ Nightly 24.0a1 2013-05-15
> HTC Desire Z (Android 2.3.3) / Samsung Galaxy S2 (Android 4.0.3)
> 
> Steps to reproduce:
> 1) Install first Aurora and then Nightly on the device
> 2) Go to Settings->Accounts & sync and try to add an Aurora sync account
> 
> Expected results:
> The user can choose the Firefox Account he can setup
> 
> Actual results:
> The account is automatically set up as a Nightly sync account and the user
> manually has to add Aurora to the sync account
> The account is set up for the latest of the 2 branches installed

This is the expected behaviour.  Internally, Nightly and Aurora share an Android account type (as do Release and Beta).  It is up to Android which package "wins" and gets to own, and therefore brand, that account type.  We have found no way to influence this -- on some devices it is the latest installed (your case), on some it is the earliest, and on some it appears random.  This arrangement was the best we could find to allow Beta users to upgrade to Release, or vice versa, while preserving their Sync account.

As for manually enabling sync for one package: we elected to not default both Firefox packages to Sync because it could be very confusing, especially if users use both simultaneously.  I would be open to revisiting this decision.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
I would suggest adding an option in the Sync interface to choose which account to sync. Granted that most people would do the sync from the app not the Settings app but it may be a nice feature
(In reply to Adrian Tamas from comment #4)
> I would suggest adding an option in the Sync interface to choose which
> account to sync. Granted that most people would do the sync from the app not
> the Settings app but it may be a nice feature

The issue is that there are several axes of choice, and we expect a tiny proportion of users to ever deviate from the standard choice.  Axes include: which Sync account to sync; which Firefox package to sync with; which Firefox profile to sync into.

When you say "which account to sync", I think you are underlining the issue: you think of the choice as between accounts, but really there is only one Sync account and there are two Firefox packages.  We didn't have a good technical story for some of this (multi-profile support has been mooted) and we certainly don't have a good UI story for most of this (on Android, inter-package communication in the face of package addition and removal is very challenging).
tracking-fennec: ? → ---

Updated

11 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.