Closed Bug 873053 Opened 8 years ago Closed 3 years ago

Intermittent B2G/Android xpcshell "AttributeError: 'NoneType' object has no attribute 'pid'"

Categories

(Testing :: XPCShell Harness, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=23030428&tree=Mozilla-Inbound

b2g_ics_armv7a_gecko_emulator_vm mozilla-inbound opt test xpcshell on 2013-05-16 06:41:55 PDT for push 9af1395c410c
slave: tst-linux64-ec2-334

06:56:00     INFO -  TEST-INFO | /builds/slave/test/build/tests/xpcshell/tests/toolkit/devtools/debugger/tests/unit/test_threadlifetime-05.js | running test ...
07:01:00     INFO -  Exception in thread Thread-36:
07:01:00     INFO -  Traceback (most recent call last):
07:01:00     INFO -    File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
07:01:00     INFO -      self.run()
07:01:00     INFO -    File "/usr/lib/python2.7/threading.py", line 755, in run
07:01:00     INFO -      self.function(*self.args, **self.kwargs)
07:01:00     INFO -    File "/builds/slave/test/build/tests/xpcshell/runxpcshelltests.py", line 895, in <lambda>
07:01:00     INFO -      testTimer = Timer(HARNESS_TIMEOUT, lambda: self.testTimeout(name, proc.pid))
07:01:00     INFO -  AttributeError: 'NoneType' object has no attribute 'pid'

command timed out: 1200 seconds without output, attempting to kill
process killed by signal 9
program finished with exit code -1
This is fallout from bug 597064.
Blocks: 597064
I suppose the only way proc can be null is if launchProcess didn't actually complete successfully? I guess we should cancel the timer in the finally block.
So the remote/b2g harnesses don't actually return a process from launchProcess:
http://mxr.mozilla.org/mozilla-central/source/testing/xpcshell/remotexpcshelltests.py#305
See Also: → 875814
Signature has morphed; updating summary (this will also reduce false positives).
Summary: Intermittent B2G xpcshell command timed out: 1200 seconds without output, attempting to kill from "AttributeError: 'NoneType' object has no attribute 'pid'" → Intermittent B2G xpcshell "AttributeError: 'NoneType' object has no attribute 'pid'"
{
17:18:09     INFO -  Exception in thread Thread-78:
17:18:09     INFO -  Traceback (most recent call last):
17:18:09     INFO -    File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
17:18:09     INFO -      self.run()
17:18:09     INFO -    File "/usr/lib/python2.7/threading.py", line 755, in run
17:18:09     INFO -      self.function(*self.args, **self.kwargs)
17:18:09     INFO -    File "/builds/slave/test/build/tests/xpcshell/runxpcshelltests.py", line 528, in <lambda>
17:18:09     INFO -      testTimer = Timer(HARNESS_TIMEOUT, lambda: self.testTimeout(name, proc.pid))
17:18:09     INFO -  AttributeError: 'NoneType' object has no attribute 'pid'
}

Hoping this might be fixed (or at least the way paved for it), by the Android equivalent, bug 875814.
Depends on: 875814
See Also: 875814
https://hg.mozilla.org/mozilla-central/rev/48fa00afe683
Assignee: nobody → mconley
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Assignee: mconley → nobody
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla28 → ---
Summary: Intermittent B2G xpcshell "AttributeError: 'NoneType' object has no attribute 'pid'" → Intermittent B2G/Android xpcshell "AttributeError: 'NoneType' object has no attribute 'pid'"
I'm not sure if it's the same issue or not, but debug b2g xpcshell just went live and they are hitting a constant failure with the same signature in test_ril_worker_sms_gsmpduhelper.js:
https://tbpl.mozilla.org/php/getParsedLog.php?id=31840617&tree=Pine

Note that they were running fine on Tuesday, the regression is somewhere in:
https://hg.mozilla.org/projects/pine/pushloghtml?startID=84&endID=85
I filed a new bug for the debug b2g xpcshell issue because it isn't intermittent. Could still share the same root cause though.
B2G is gone.
Status: REOPENED → RESOLVED
Closed: 7 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.