about: page favicons are not displayed in the "Your tabs from last time" section of about:home screen

VERIFIED FIXED in Firefox 23

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: nalexander, Assigned: Margaret)

Tracking

Trunk
Firefox 24
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23 verified, firefox24 verified)

Details

Attachments

(5 attachments)

Screenshots will say it best.
This is not specific to about:feedback.
margaret, wesj: I think y'all were working in this area recently.
Assignee

Comment 5

6 years ago
I can look into this.
Assignee: nobody → margaret.leibovic
Assignee

Comment 6

6 years ago
So, there are two issues here.

The main issue with about: pages is that we don't store about: URLs in history, so we're not finding a favicon for them when we call getFaviconForUrl in readLastTabs. The favicon *does* show up for about:firefox because it's a bookmark, so if you bookmark about:feedback, you will see the favicon show up ;) I'm not sure if it's worth fixing this issue, since it's rooted in how we handle history entries for about: pages.

The second issue here is that when we don't find a favicon, we never end up calling updateImage, so we get that awkward white square. This is something that should definitely be fixed.
Assignee

Comment 7

6 years ago
Here's a patch to fix the second issue I mentioned in my last comment.
Attachment #750682 - Flags: review?(bnicholson)
Attachment #750682 - Flags: review?(bnicholson) → review+
Assignee

Comment 9

6 years ago
This was a regression from bug 839855 (I tested in beta, and we show the default favicon for about:feedback in tabs from last time).
Blocks: 839855
Assignee

Comment 10

6 years ago
Comment on attachment 750682 [details] [diff] [review]
Use default favicon in "tabs from last time" if there's no stored favicon

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 839855
User impact if declined: about: pages have an ugly favicon in tabs from last time
Testing completed (on m-c, etc.): tested locally
Risk to taking this patch (and alternatives if risky): low-risk background change
String or IDL/UUID changes made by this patch: n/a
Attachment #750682 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/da75ba983321
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Attachment #750682 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 24.0a1(2013-06-20) and Firefox for Android 23.0a2(2013-06-20)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.