Rendered image alt text causes cell size calculation to fail

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: jsp, Assigned: karnaze (gone))

Tracking

(Blocks: 1 bug, {regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl])

Attachments

(1 attachment)

4.64 KB, text/html
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+)
Gecko/20010620
BuildID:    2001062004

If table cells have borders, and the widest cell in a column contains an image's
alt text because the image can't be loaded, the width of the cell with the alt
text is wider than corresponding cells in other rows by the width of any borders.

Reproducible: Always
Steps to Reproduce:
1. Load the attached test case.
2. Look at each of the tables.

Actual Results:  Cells with borders and broken images are wider than the
corresponding cells in other rows.

Expected Results:  The first cell of each row in each table should have the same
width as the first cell of all other rows in the table.

I'm pretty sure this is a regression. I'll try other builds once this bug is filed.
(Reporter)

Comment 1

17 years ago
Created attachment 39705 [details]
Test case.
(Reporter)

Comment 2

17 years ago
The is a regression. The test case works in 0.8.1, but not in 0.9 or later.

It also fails on the Mac with 0.9.
Seeing this on Sun build 2001-06-22-10 as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

17 years ago
adding depends, regression
Depends on: 41924
Keywords: regression
(Reporter)

Comment 5

17 years ago
Does this truly depend on 41924? It doesn't really matter what content is
substituted for the image; the problem is that the width of that substituted
content is used to adjust the width of the affected cell, but none of the other
cells in the table are adjusted. I'm not an expert on the code, but it looks
likely from the outside that this bug could be fixed without 41924 being
addressed. (Especially since it was introduced long after that bug was filed.)
No longer depends on: 41924
Blocks: 41924
Keywords: testcase
It doesn't depend on bug 41924, it blocks bug 41924. Bug 41924 is also acting as
an alt text uber bug.

Updated

16 years ago
Whiteboard: [awd:tbl]
(Assignee)

Comment 7

16 years ago
wfm, 12/7/1 win2k debug
(Assignee)

Comment 8

16 years ago
ditto
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

16 years ago
WFM with 2001120703.

Comment 10

16 years ago
Verified WFM with build ID 20011207
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.