Form assistant suggestions is not dismissed while entering different letters

VERIFIED FIXED in Firefox 23

Status

()

VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: ioana.chiorean, Assigned: Margaret)

Tracking

({regression, reproducible})

23 Branch
Firefox 24
ARM
Android
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 unaffected, firefox22 unaffected, firefox23+ verified, firefox24+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build: Aurora 23.0a2 05/16
Device: Asus Eee Transformers 
OS: Android 4.0.3

Steps to Reproduce:
1. Go to gmail.com
2. Enter a user name - tap enter - repeat with a different user name
3. Enter a 3rd user name - starting with different letter from the above 2

Expected Results:
- no suggestion present 

Actual Results:
- the first 2 names as present as suggestions 

Please see video - http://www.youtube.com/watch?v=pq2Wnc4mXVM . Suggestions can be dismissed if you will tap outside the form.

Updated

5 years ago
tracking-fennec: --- → ?
Keywords: regression, regressionwindow-wanted, reproducible
The regression window for this issue is:
1. mozilla central
good build: 11.05.2013 
bad build:  12.05.2013 

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=179e29a23c56&tochange=d68224f5325b

2. inbound
good build: 1368163665
bad build:  1368166544

pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6035591d40f8&tochange=96fe69d53f35
Keywords: regressionwindow-wanted
Looks like async form history broke this.
Blocks: 566746, 697377
tracking-firefox24: --- → ?
tracking-firefox-esr17: --- → ?
tracking-firefox23: --- → ?
tracking-firefox-esr17: ? → ---
(Assignee)

Comment 3

5 years ago
I'll investigate.
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 4

5 years ago
Created attachment 751868 [details] [diff] [review]
patch

Yo dawg, there are a lot of callbacks in this code. Turns out there were two slight logic errors that caused us to never call _hideFormAssistPopup when we should.
Attachment #751868 - Flags: review?(mark.finkle)
Comment on attachment 751868 [details] [diff] [review]
patch

Off topic: I just realized I have a strong dislike for "fat arrow" function syntax. It's the work of the devil.
Attachment #751868 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 7

5 years ago
Comment on attachment 751868 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 566746
User impact if declined: form autocomplete popup doesn't hide when it should
Testing completed (on m-c, etc.): tested locally (just landed on inbound)
Risk to taking this patch (and alternatives if risky): low-risk, isolated small logic fixes
String or IDL/UUID changes made by this patch: n/a
Attachment #751868 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a239a5d19439
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
tracking-firefox23: ? → +
tracking-firefox24: ? → +
Attachment #751868 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/a6ec7be9af2c
status-firefox23: affected → fixed
status-firefox24: affected → fixed

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
status-firefox24: fixed → verified
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.