The default bug view has changed. See this FAQ.

No title or icon in titlebar for popup windows

RESOLVED FIXED in Firefox 28

Status

()

Firefox
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

({regression})

Trunk
Firefox 28
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M5])

Attachments

(1 attachment, 1 obsolete attachment)

1.34 KB, patch
dao
: review+
Details | Diff | Splinter Review
(Assignee)

Description

4 years ago
STR:

1. Open a window using: window.open("http://www.mozilla.org/", "_new", "height=500&width=500")
2. Try to read the page title from the top of the window


AR: no page title nor icon
ER: page title and icon, as on Nightly


AFAICT this is because in updateTitlebarDisplay, we're now only using gInPrintPreviewMode to determine whether to show the titlebar and change the chrome margins.

I believe this also causes some of our test failures, eg. the queryCaretRectWin failures in mochitest-other (chrome).
(Assignee)

Comment 1

4 years ago
Created attachment 751012 [details] [diff] [review]
Patch

I believe the original removal of the window.menubar.visible bits was a mistake (as these are barprops and don't necessarily say anything about whether the actual XUL element is visible), so I've more or less changed that back (although calling it displayAppButton didn't make sense so I've called it drawInTitlebar instead). I *have* left out the check whether the menubar is autohidden, which I guess won't make sense anymore.

This fixes the issue I was seeing.

It also fixes the test I was originally looking at (test_queryCaretRect), as a side-effect.
Attachment #751012 - Flags: review?(dao)
Comment on attachment 751012 [details] [diff] [review]
Patch

Since this isn't about the app menu button anymore, it's unclear to me why this behavior should depend on window.menubar.visible.

I believe you should use window.toolbar.visible. That's what tabbrowser uses to hide the tab bar in popups.
Attachment #751012 - Flags: review?(dao) → review-

Updated

4 years ago
Blocks: 813802
No longer depends on: 813802
Keywords: regression
(Assignee)

Comment 3

4 years ago
Created attachment 751057 [details] [diff] [review]
Patch v2

OK. This works just as well in a quick test, so here we go...
Attachment #751012 - Attachment is obsolete: true
Attachment #751057 - Flags: review?(dao)

Updated

4 years ago
Attachment #751057 - Flags: review?(dao) → review+
(Assignee)

Comment 4

4 years ago
Pushed: https://hg.mozilla.org/projects/ux/rev/1ce330b1e8f4
Whiteboard: [Australis:M5] → [Australis:M5][fixed-in-ux]
(Assignee)

Comment 5

3 years ago
https://hg.mozilla.org/mozilla-central/rev/1ce330b1e8f4
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M5][fixed-in-ux] → [Australis:M5]
Target Milestone: --- → Firefox 28

Updated

3 years ago
Keywords: verifyme

Comment 6

3 years ago
Not reproducible locally (05/17 Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20130517 Firefox/24.0).
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.