[keon] builds break due to non-applied patch on gp-keon-kernel (copybit.cpp error)

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
P1
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: fredy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

I have described the problem on geeksphone forum as the problem is located on their repository.[1]

The error:

target thumb C++: copybit.msm7627a <= hardware/qcom/display/libcopybit/copybit.cpp
hardware/qcom/display/libcopybit/copybit.cpp:89: warning: missing initializer for member 'hw_module_t::dso'
hardware/qcom/display/libcopybit/copybit.cpp:89: warning: missing initializer for member 'hw_module_t::reserved'
hardware/qcom/display/libcopybit/copybit.cpp: In function 'int msm_copybit(copybit_context_t*, const void*)':
hardware/qcom/display/libcopybit/copybit.cpp:229: warning: comparison between signed and unsigned integer expressions
hardware/qcom/display/libcopybit/copybit.cpp:230: warning: format '%08lx' expects type 'long unsigned int', but argument 19 has type 'unsigned int'
hardware/qcom/display/libcopybit/copybit.cpp: In function 'int stretch_copybit(copybit_device_t*, const copybit_image_t*, const copybit_image_t*, const copybit_rect_t*, const copybit_rect_t*, const copybit_region_t*)':
hardware/qcom/display/libcopybit/copybit.cpp:389: warning: comparison between signed and unsigned integer expressions
hardware/qcom/display/libcopybit/copybit.cpp:390: warning: comparison between signed and unsigned integer expressions
hardware/qcom/display/libcopybit/copybit.cpp: In function 'int fill_color(copybit_device_t*, const copybit_image_t*, const copybit_rect_t*, uint32_t)':
hardware/qcom/display/libcopybit/copybit.cpp:515: error: 'struct mdp_blit_req' has no member named 'const_color'
hardware/qcom/display/libcopybit/copybit.cpp:516: error: 'struct mdp_blit_req' has no member named 'const_color'
hardware/qcom/display/libcopybit/copybit.cpp:518: error: 'struct mdp_blit_req' has no member named 'const_color'
hardware/qcom/display/libcopybit/copybit.cpp:519: error: 'struct mdp_blit_req' has no member named 'const_color'
hardware/qcom/display/libcopybit/copybit.cpp:520: error: 'struct mdp_blit_req' has no member named 'const_color'
hardware/qcom/display/libcopybit/copybit.cpp:523: error: 'CONST_COLOR' was not declared in this scope
make: *** [out/target/product/keon/obj/SHARED_LIBRARIES/copybit.msm7627a_intermediates/copybit.o] Error 1

[1] http://forum.geeksphone.com/index.php?topic=5184.msg58457
fredy, thanks for reporting this! Now that I've read your description over on the geeksphone forum, I think you are asking whoever maintains the geeksphone/keon build to commit this. I'm not sure if reporting the bug here is going to help in that process.  But on the other hand, reportingit in the geeksphone user forums also may not help.  

ochameau, do you know what the right thing to do with this bug (and fix) is? Where is the best place to report it?
Flags: needinfo?(poirot.alex)
I can confirm that the following diff is enough to fix the build failure. I need to know how patching is handled in the buildsystem ...

$ git diff
diff --git a/include/linux/msm_mdp.h b/include/linux/msm_mdp.h
index 0ac1cf1..61c6e24 100644
--- a/include/linux/msm_mdp.h
+++ b/include/linux/msm_mdp.h
@@ -120,6 +120,7 @@ enum {
 #define MDP_FLIP_LR 0x1
 #define MDP_FLIP_UD 0x2
 #define MDP_ROT_90 0x4
+#define CONST_COLOR 0x0000100
 #define MDP_ROT_180 (MDP_FLIP_UD|MDP_FLIP_LR)
 #define MDP_ROT_270 (MDP_ROT_90|MDP_FLIP_UD|MDP_FLIP_LR)
 #define MDP_DITHER 0x8
@@ -207,11 +208,19 @@ struct mdp_csc {
 
 #define MDP_BLIT_REQ_VERSION 2
 
+struct color {
+       uint32_t r;
+       uint32_t g;
+       uint32_t b;
+       uint32_t alpha;
+};
+
 struct mdp_blit_req {
        struct mdp_img src;
        struct mdp_img dst;
        struct mdp_rect src_rect;
        struct mdp_rect dst_rect;
+       struct color const_color;
        uint32_t alpha;
        uint32_t transp_mask;
        uint32_t flags;
Liz, I'm not an expert on low level b2g build system, but more focused on gaia one.
It looks like the issue is fixed, right?
http://forum.geeksphone.com/index.php?topic=4834.msg58495#msg58495

Otherwise, mwu on #b2g is my main contact about b2g build system.
Flags: needinfo?(poirot.alex)
mwu, I thought you might want to talk with gerard-majax and fredy about this issue since they have such specific information and a patch to submit. Though the geeksphone forum does seem to promise a fix is coming. Is there something we can do to help, or is it best to wait a week, or to close this?
Flags: needinfo?(mwu)
(In reply to Alexandre Poirot (:ochameau) from comment #3)
> Liz, I'm not an expert on low level b2g build system, but more focused on
> gaia one.
> It looks like the issue is fixed, right?
> http://forum.geeksphone.com/index.php?topic=4834.msg58495#msg58495
> 
> Otherwise, mwu on #b2g is my main contact about b2g build system.

It is fixed for the Peak, and since according to the message you link it seems on his way to be fixed, I think we should close this.
I am disabling the needinfo request as we have already make available the patch through https://github.com/mozilla-b2g/gonk-patches.

The problem was and is located on geeksphone side, I opened this bug here in order to keep track and to inform other people with the same problem.

I am watching daily the repositories of geeksphone, so I'll close this bug as soon as it gets solved.

Although it would be interesting to know in which way we should handle such bugs in the future.

Is there anyone from geeksphone, we can cc on bugs like that?
Is there any way to contact geeksphone other than their forum?
Flags: needinfo?(mwu)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.