Heavily transformed images in SVG's causing performance issues (choppy scrolling)

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: ben.aiken, Unassigned)

Tracking

({perf})

20 Branch
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

Scrolling around on a page with a very large image (6000px x 6000px, 54dpi) that is scaled down causes choppy scrolling. 


Actual results:

The browser window stutters immensely.


Expected results:

There shouldn't be chopping scrolling.
Reporter

Comment 1

6 years ago
Per request from Robert O'Callahan, this bug has been created as a clone of Bug 865546. While Bug 865546's fix helps performance, it still has some issues.

Need to profile and attach results.
Reporter

Comment 2

6 years ago
I'm actually having trouble profiling for any build 2013-01-18 and after. I had someone else on my team confirm the same thing. When I "Stop" the profiling, the profiling data shows up briefly and then almost immediately disappears. 

I am going to attach a video of this happening.
Reporter

Comment 3

6 years ago
Reporter

Comment 6

6 years ago
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #5)
> Did you install the latest profiler XPI from here?
> https://github.com/bgirard/Gecko-Profiler-Addon/raw/master/geckoprofiler.xpi

Thanks for this - I'll give it a try and report back later today.
Keywords: perf
Depends on: 764299
Performance seems to have gotten a lot better between 2013-05-09-03-10-47-mozilla-central and 2013-05-10-04-16-06-mozilla-central.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ea059733677c&tochange=08be63954b6b
And in latest Nightly it seems to be even better yet.
Reporter

Comment 9

6 years ago
Okay great. I will give it a try and report back. Haven't gotten a chance to do profiling on my side but will be pushing things around in my schedule to do that today. I'll also take a look at the latest nightly and see how that performs.

Thanks!
Reporter

Comment 10

6 years ago
While the performance isn't 100% of what it was before, we've also implemented some enhancements that negate the performance loss. Because of this, I'm comfortable marking this one as resolved and will reopen a new issue if the performance issues resurface. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.