Closed Bug 873727 Opened 7 years ago Closed 7 years ago

Intermittent Windows iX test_showcaret.xul | uncaught exception - ReferenceError: testScroll is not defined, | [SimpleTest.finish()] this test already called finish!, | called finish() multiple times

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: philor, Assigned: jsbruner)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 2 obsolete files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=23100442&tree=Mozilla-Inbound
Windows XP 32-bit mozilla-inbound pgo test mochitest-other on 2013-05-17 18:21:00 PDT for push d7155fcfc6a9
slave: t-xp32-ix-019

https://tbpl.mozilla.org/php/getParsedLog.php?id=23105977&tree=Mozilla-Inbound
Windows XP 32-bit mozilla-inbound pgo test mochitest-other on 2013-05-17 21:37:05 PDT for push 8a53b2daa50e
slave: t-xp32-ix-026

19:27:32     INFO -  25824 INFO TEST-PASS | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_showcaret.xul | hbox still focused in other window after down movement
19:27:32     INFO -  25825 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_showcaret.xul | uncaught exception - ReferenceError: testScroll is not defined at chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_showcaret.xul:93
19:27:32     INFO -  25826 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_showcaret.xul | [SimpleTest.finish()] this test already called finish!
19:27:32     INFO -  25827 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_showcaret.xul | called finish() multiple times
19:27:32     INFO -  25828 INFO TEST-END | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_showcaret.xul | finished in 105ms

With just one slave I was fully prepared to blame the slave, but with two I'm less sure.
Summary: Intermittent iX WinXP test_showcaret.xul | uncaught exception - ReferenceError: testScroll is not defined, | [SimpleTest.finish()] this test already called finish!, | called finish() multiple times → Intermittent Windows iX test_showcaret.xul | uncaught exception - ReferenceError: testScroll is not defined, | [SimpleTest.finish()] this test already called finish!, | called finish() multiple times
Blocks: 874922
No longer blocks: winxp-ix-releng
Regressed by bug 868432:
http://hg.mozilla.org/mozilla-central/diff/aab37a39c92a/toolkit/content/tests/chrome/test_showcaret.xul

Josiah, please may you take a look? :-)
Blocks: 868432
Flags: needinfo?(josiah)
(In reply to Ed Morley [:edmorley UTC+1] from comment #30)
> Regressed by bug 868432:
> http://hg.mozilla.org/mozilla-central/diff/aab37a39c92a/toolkit/content/
> tests/chrome/test_showcaret.xul
> 
> Josiah, please may you take a look? :-)

Oh shoot. Yeah, it's probably my fault. :-(

I'll take a closer look a little later.
Flags: needinfo?(josiah)
Attached patch Fix Failure (obsolete) — Splinter Review
This patch *should* fix the problem. Here's the logic behind the fix:

"uncaught exception - ReferenceError: testScroll is not defined". This was caused by an inconsistent use of self to create the interval, but then window to clear it.

"[SimpleTest.finish()] this test already called finish!, | called finish() multiple times". This was probably caused by the fact that the "new" code added by the bug that caused this one was placed *after* the event listener (the one that causes finish). If the event listener took a little longer to complete, then the other part of the test will have finished and everything should work as expected. If that listener method finishes too early, then part of the test will get interrupted. Hence the intermittent failure.

Running this patch on try here: https://tbpl.mozilla.org/?tree=Try&rev=1c7da953ebba

Seems to be going well for now.
Assignee: nobody → josiah
Status: NEW → ASSIGNED
Nope. Didn't work at all. Too bad it wasn't that easy.
Attached patch Fix Failure (obsolete) — Splinter Review
Hopefully this fixes it. I switched to a scroll listener instead of using a series of timers which should keep things from getting out of sync.

Try run is here: https://tbpl.mozilla.org/?tree=Try&rev=c6828464faa4

Will continue adding pushes for awhile to see if this fixes the problem...
Attachment #760868 - Attachment is obsolete: true
Attached patch Fix FailureSplinter Review
Fixed indentation.

Robert, could you review this? The try run looks good.
Attachment #764706 - Attachment is obsolete: true
Attachment #764854 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/77e0dd13bb1e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.