[HiDPI] Wrong screen resolution, websites zoomed in

RESOLVED DUPLICATE of bug 851268

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 851268
5 years ago
4 years ago

People

(Reporter: salmarina, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 751308 [details]
After update

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130514181517

Steps to reproduce:

Today Firefox beta updated to v22


Actual results:

All websites are "zoomed in". Images are pixelated due to the bigger dimensions, and fonts are also bigger. Some favicons are also pixelated too. Even more, Firefox icons (back, forward, home...) are pixelated too.
It seems like Firefox is giving me the UI of a 1600px width screen while mine is 1920px.
I've found that this website: foro.universojuegos.es is giving me the 1600px background image, not the 1920px one. Of course I've used Ctrl+0 to zoom out, but it's already resetted.


Expected results:

If I zoom out two times I see the websites as usually, without pixelated images and big fonts.
(Reporter)

Comment 1

5 years ago
Created attachment 751309 [details]
Before the update (or zoomed out twice).

This is how the website should look like. This is the way it has been for a long time, until Firefox v22

Comment 2

5 years ago
Could you test the website rendering with a new profile and FF22, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

What are the resolution settings in Win 7? 100%?
Flags: needinfo?(salmarina5)
(Reporter)

Comment 3

5 years ago
Done, the bug is still present after creating a new profile. Tabbed favicons are pixelated, Firefox home/back/... buttons are pixelated too. And the example website (foro.universojuegos.es) looks zoomed in.

Windows 7 display settings are the default ones: 1920x1080px, 100%. I haven't changed anything there.

Let me know if you need more information.
Flags: needinfo?(salmarina5)

Comment 4

5 years ago
Ok, it's due to HiDPI feature new in Firefox 22.

Updated

5 years ago
Summary: Wrong screen resolution, websites zoomed in → [HiDPI] Wrong screen resolution, websites zoomed in
(Reporter)

Comment 5

5 years ago
Firefox has just updated (it says Firefox 22, beta channel) and the bug is still present.

This should be fixed, it really makes Firefox look horrible (and websites also) because all images/icons are pixelated, everywhere.

Comment 6

5 years ago
Just updated my Firefox to v22 and suddenly all the sites are coming as zoomed in. This is weird, I've to press Ctrl-- in order to get the desired optimal size.

If this is a feature, any way to turn this off?
(Reporter)

Comment 7

5 years ago
41 days since the bug was reported... any news? Is this going to be fixed?

Comment 8

5 years ago
It's not a bug, just play with layout.css.devPixelsPerPx.
(Reporter)

Comment 9

5 years ago
Not a bug @Loic? Sorry but I don't understand:
"A software bug is an error, flaw, failure, or fault in a computer program or system that produces an incorrect or unexpected result, or causes it to behave in unintended ways".
Try to zoom in all websites twice and let me know if you consider it an "expected result"...

I will play with layout.css.devPixelsPerPx (I'm not at home now) and post the results but that property should be ok by default (nobody should enter about:config after installing Firefox to see websites correctly).

Comment 10

5 years ago
Just make a test with a new profile, especially if you set in the past some zoom levels for your regular websites, so you will be the difference.

Comment 11

5 years ago
I was browsing a site and wanted to check my Firefox version. I went to Help > About Firefox and it showed me v21.0 and was also showing me that its receiving an update. After that updated is done it asked me to restart firefox and I did. After that the same site which I was browsing earlier opened up but is zoomed out. even the tabs and the back next button in firfox looked zoomed out.

My point is nothing else is changed, Whatever I was viewing on v21.. after the upgrade to v22 got zoomed.
(Reporter)

Comment 12

5 years ago
I've already tried with a new profile (https://bugzilla.mozilla.org/show_bug.cgi?id=873738#c3) but all websites are zoomed. All, even websites I've never visited in my life. All websites have zoom x2. And if I try to reset the zoom (with Ctrl+0) it keeps with 2x zoom.

I've played with layout.css.devPixelsPerPx and I've found that using value "1.0" seems to solve the problem, I mean, websites are now displayed correctly. But the Firefox UI is now too small and doesn't fit very well (I've attached 2 screenshots, look at the top right corner). UI fonts are too small as you can see.
(Reporter)

Comment 13

5 years ago
Created attachment 768267 [details]
layout.css.devPixelsPerPx = 1.0
(Reporter)

Comment 14

5 years ago
Created attachment 768268 [details]
layout.css.devPixelsPerPx = -1.0 (default)
(Reporter)

Comment 15

5 years ago
Ok, after restarting Firefox (using layout.css.devPixelsPerPx = 1.0) the UI fits correctly.
I still think that the fonts are too small but that could be a wrong impression (I've been using v22 for 40 days, can't remember how it looked before).

Comment 16

5 years ago
I just noticed that under Control Panel > Display the setting is set to Medium - 125% (default). If I change that to Smaller - 100%, the firefox comes up fine without zoomed.

But what's weird is that I was using my machine at Medium 125% and the earlier version of firefox i.e. v21 worked fine in it... this is v22 which started zooming in. Now I've to live with overall smaller fonts if I want to use firefox correctly.. not good.. there should be a UI setting to fix this.

Comment 17

5 years ago
As I said, there is no bug, Firefox uses the default value defined for the screen resolution in the Windows config panel. If you have a full HD screen and you set a resolution of 150%, Firefox will use this value to render its UI and webpages.
Just play with layout.css.devPixelsPerPx to change the UI resolution and use zoom levels (or add-on like NoSquint) to change the rendering of webpages.

Comment 18

5 years ago
(In reply to Satpal Sharma from comment #16)
> I just noticed that under Control Panel > Display the setting is set to
> Medium - 125% (default). If I change that to Smaller - 100%, the firefox
> comes up fine without zoomed.
> 
> But what's weird is that I was using my machine at Medium 125% and the
> earlier version of firefox i.e. v21 worked fine in it... this is v22 which
> started zooming in. Now I've to live with overall smaller fonts if I want to
> use firefox correctly.. not good.. there should be a UI setting to fix this.

You really need to read the release notes of Firefox 22:
http://www.mozilla.org/en-US/firefox/22.0/releasenotes/
"Windows: Firefox now follows display scaling options to render text larger on high-res displays"
(Reporter)

Comment 19

5 years ago
I also have 125% in Windows Control Panel (first time I see that).
It seems that Windows uses 125% on HD screens and 100% in smaller ones.

So Loic was right, this is not a real bug. I'm sorry Loic.

But now that we are here, dont you think firefox should warn HD screen users about this feature, so that they can change windows settings or tell firefox to ignore them?
A lot of people is going to complain about this change, or just change its browser.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Widget: Win32
Product: Firefox → Core
Resolution: --- → INVALID

Comment 20

5 years ago
Agreed this is not a bug. But do you expect every user to read the release notes??
Like salmarina mentioned.. User will see it as a bug and will be confused. We should have a way to tell the users about it.

Updated

4 years ago
Duplicate of this bug: 890300

Updated

4 years ago
Duplicate of this bug: 890202

Comment 23

4 years ago
I disagree. I think it is a bug because Firefox should behave properly regardless the user screen setup. Many times downsizing your screen to a 100% value is not an option due to the specific display settings you need for your work (as in my case).
The proposed solution (installing NoSquint and setting default zoom to 80%) is only a patch that resolves perfectly the issue about web content, but not the ugly appearance of the navigation toolbar icons, bookmark toolbar icons and tab strip.
I think it should be properly resolved at future versions in order to keep the high standards that have so far distinguished Firefox.
I'm not a programmer, but I guess if it has been developed a routine that automatically detects high resolution screen and enable high sizes, it could be relatively easy to develop another that could detect 125% screen setup and also automatically disable them.
(Reporter)

Comment 24

4 years ago
Paco Ramos you can go to "about:config" in Firefox (write that without quotes in the URL bar) and search for "layout.css.devPixelsPerPx" (again without quotes).
You can double click that property and set a value of 1.0 so that Firefox will not use the default 1.25 that windows tells him to use (that is, 125% zoom). Restart Firefox.

The other option is setting 100% in windows, but as you say that's not always the best option.

I think Firefox should warn the user about this behavior (when a non 100% zoom is detected in windows), and let him decide:
- Ignore windows zoom option (that is layout.css.devPixelsPerPx = 1.0)
- Change windows zoom option (just guide users how to change it)
- Leave it without changes (125% zoom to Firefox)


More duplicate (not-)bugs will come, some users will leave firefox, others will start complaining until this changes, cause almost all users don't know that windows uses 125% by default in big screens.

Comment 25

4 years ago
(In reply to pacorramos from comment #23)
> The proposed solution (installing NoSquint and setting default zoom to 80%)
> is only a patch that resolves perfectly the issue about web content, but not
> the ugly appearance of the navigation toolbar icons, bookmark toolbar icons
> and tab strip.

Bug 878288 - Create high resolution icon set for Windows
Bug 854956 - use higher-res favicons in bookmarks, awesomebar results, etc

Just play with layout.css.devPixelsPerPx in about:config and reset the zoom level for your current websites.

Comment 26

4 years ago
Thank you salmarina and Loic.
I did the change at "layout.css.devPixelsPerPx" to 1.0 and reset NoSquint default zoom size to 100%, but, alas, now all in Firefox interface (not web content) is too small, specially interface text: bookmarks, options, menu items, right-click popup items... I mean, compared with previous versions of Firefox until 21 (or even, for instance, with current version of Thunderbird).
Trying other values (as -0.5 or 0.5) gives odd results, so I've reverted to -1.0 value. Is seems it's the lesser of two evils...

Comment 27

4 years ago
(In reply to pacorramos from comment #26)
> Trying other values (as -0.5 or 0.5) gives odd results, so I've reverted to
> -1.0 value. Is seems it's the lesser of two evils...

-1.0 is the default value but it's by convention. It's not the real value.
Try values around 1.0 and 1.5 (by 0.01). Many people have selected 1.20 or 1.25.

Comment 28

4 years ago
Thank you, Loic. It seems 1.22 does the trick for me.

Updated

4 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 851268
You need to log in before you can comment on or make changes to this bug.