Last Comment Bug 874003 - Remove preventBubble and preventCapture
: Remove preventBubble and preventCapture
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla24
Assigned To: Masatoshi Kimura [:emk]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 03:04 PDT by David Bruant
Modified: 2013-05-24 08:29 PDT (History)
3 users (show)
VYV03354: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (14.30 KB, patch)
2013-05-20 14:05 PDT, Masatoshi Kimura [:emk]
bugs: review+
Details | Diff | Splinter Review

Description David Bruant 2013-05-20 03:04:50 PDT
There is no plan in make a standard out of these Mozilla-specific methods. stopPropagation is what is used by developers (standard and better cross-browser compat)
They have no reason to exist as properties on Event.prototype anymore.
Comment 1 Olli Pettay [:smaug] (vacation Aug 25-28) 2013-05-20 08:17:50 PDT
Need to be careful especially with preventBubble. Traditionally it has been used oddly often.
Comment 2 Masatoshi Kimura [:emk] 2013-05-20 14:05:39 PDT
Created attachment 751836 [details] [diff] [review]
patch

Let's try and see what's going on early in the cycle.
Currently preventBubble is no-op, so any code depending on preventBubble is broken anyway.
Try result: https://tbpl.mozilla.org/?tree=Try&rev=0fe79854849d
Comment 4 Ryan VanderMeulen [:RyanVM] 2013-05-21 10:46:52 PDT
https://hg.mozilla.org/mozilla-central/rev/343242181775
Comment 5 Kohei Yoshino [:kohei] 2013-05-21 11:34:02 PDT
Updated:
https://developer.mozilla.org/en-US/docs/Web/API/Event
https://developer.mozilla.org/en-US/docs/XPCOM_Interface_Reference/nsIDOMEvent
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_24

We should also consider removing (Bug 691151) or deprecating (Bug 726933) getPreventDefault. The nsIDOMEvent document says it has been deprecated since Gecko 16.0 but the bugs are still open.
Comment 6 Masatoshi Kimura [:emk] 2013-05-21 20:16:26 PDT
(In reply to Kohei Yoshino from comment #5)
> https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_24

I think preventBubble and preventCapture should be explained in a separate clause.
These methods are not derived from Netscape but from the earlier W3C draft.
Chromium have never supported these methods from the start. And the replacement method is stopPropagation.
Comment 7 Kohei Yoshino [:kohei] 2013-05-24 08:29:04 PDT
(In reply to Masatoshi Kimura [:emk] from comment #6)
> I think preventBubble and preventCapture should be explained in a separate
> clause.
> These methods are not derived from Netscape but from the earlier W3C draft.
> Chromium have never supported these methods from the start. And the
> replacement method is stopPropagation.

Thank you for the feedback. I just corrected the document.

Note You need to log in before you can comment on or make changes to this bug.