Rotating IP causes problems with buglist.cgi

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Query/Bug List
P3
normal
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: CodeMachine, Assigned: Olav Vitters)

Tracking

2.13
Bugzilla 3.0

Details

(Whiteboard: [blocker will fix])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
It seems my wonderful rotating IP is bringing out all manner of Bugzilla bugs
today.  Try this one out:

Go to a stored query.  The pondering screen seems to redirect you to a URL that
is just "buglist.cgi".  That's bad in itself (not bookmarkable), but at the
moment we'll just assume that in the meantime my IP changed.  Hence you'll see a
logged out footer.

Click on "Change Several Bugs At Once".  At this point, if you're not lucky
enough for your IP to become the right one again, you'll get a log in screen
that looks absolutely lovely.
(Reporter)

Comment 2

17 years ago
Created attachment 39786 [details]
The HTML output.
(Reporter)

Comment 3

17 years ago
Oh, and this is reproduced under both N4.77 and Mozilla.
(Reporter)

Comment 4

17 years ago
And if you _do_ try to log in you get an empty bug list coming out the other
end.
(Reporter)

Updated

17 years ago
Target Milestone: --- → Bugzilla 2.16
(Reporter)

Comment 6

17 years ago
Created attachment 40056 [details]
Screen 2

Comment 7

17 years ago
The issue here appears to be similar to bug 80045.  The solution is a little
more complex.  In bug 80045 simply adding a \n before printing anything else was
the solution, in this instance, we'll have to deal with the multipart stuff that
allows there to be a "Please Stand By" page.
(Reporter)

Updated

17 years ago
Priority: -- → P3
->New (old by now?) product Bugzilla
Assignee: tara → endico
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → 2.13
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Assignee: endico → nobody

Comment 10

14 years ago
These bugs appear to be abandoned.  Retargeting to 2.20
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20

Comment 11

13 years ago
Does this still happen, actually? We fixed most of the rotating-IP problems, I
thought...
Summary: Weird screen. → Rotating IP causes problems with buglist.cgi
Target Milestone: Bugzilla 2.20 → ---

Comment 12

12 years ago
I'm still having problems with dynamic IPs. I have to login again and again just because I move my notebook between different networks.
(Assignee)

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Comment 13

11 years ago
Fixed as per default we now set loginnetmask to 0. Meaning people can choose to disable the IP restriction.
Assignee: nobody → bugzilla-mozilla
Depends on: 357873
Whiteboard: [blocker will fix]
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.