Intermittent content/events/test/test_bug656379-1.html | Releasing the mouse over the label should have unpressed (and focused) the button.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: smaug)

Tracking

({intermittent-failure})

Trunk
x86
Windows 8
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox24 disabled, firefox25 affected, firefox26 affected)

Details

(Whiteboard: [pgo])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 751741 [details]
expected image from log

https://tbpl.mozilla.org/php/getParsedLog.php?id=23107841&tree=Mozilla-Inbound

WINNT 6.2 mozilla-inbound pgo test mochitest-1 on 2013-05-18 00:26:15 PDT for push a20b345ae2cb
slave: t-w864-ix-039

00:35:02     INFO -  77056 INFO TEST-START | /tests/content/events/test/test_bug656379-1.html
00:35:02     INFO -  77057 INFO TEST-PASS | /tests/content/events/test/test_bug656379-1.html | Pressed focused buttons should look different from normal buttons. - got undefined and undefined
00:35:02     INFO -  77058 INFO TEST-PASS | /tests/content/events/test/test_bug656379-1.html | Pressed focused buttons should look different from normal focused buttons. - got undefined and undefined
00:35:02     INFO -  77059 INFO TEST-PASS | /tests/content/events/test/test_bug656379-1.html | Pressing the label should have pressed the button. - got undefined and undefined
00:35:02     INFO -  77060 INFO TEST-PASS | /tests/content/events/test/test_bug656379-1.html | Moving the mouse down from the label should have unpressed the button. - expected undefined
00:35:02     INFO -  77061 INFO TEST-PASS | /tests/content/events/test/test_bug656379-1.html | Moving the mouse back on top of the label should have pressed the button. - expected undefined
00:35:03     INFO -  77062 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug656379-1.html | Releasing the mouse over the label should have unpressed (and focused) the button. - expected data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAC0AAAAUCAYAAAAZb7T/AAAAzUlEQVRIie2VbQ7DIAiGOQ/34Tzch/N4n3c/1g/q1DpdnFt8kyYSLDwgtoQfFH0boEULepT+BdogRKD4YUUYz5dUBpqhEWFQrgT376dj9aoaGkHBJLDbkBNBB2WQWGbPbgcoJ0br2Bv5Lye3xVA5/JyptnGmc9ClNWBCrvDY3vLuduFkqztt4sFboBNxL2ClmI3QzwQ5gArQZOdKRX0MuqYrE3X6dTwI5/ixu2w9M90FXfFzMX/L1SU4vxBifn31vXe5b6Hn14IepQU9Sg+q46CZUdLKDwAAAABJRU5ErkJggg== but got data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAC0AAAAUCAYAAAAZb7T/AAAAsElEQVRIie2UYQ6AIAiF3yU8hZfoEl7CU3Rz+6PF3shSW8kWGxuE4JeCSAYFXwP0yA6NFdPrDz0HNBR1FqAjJS0N4DJfq/UadMzfTUEvSPCVNcV30NurrJVxvjnkfSDsJmhWbQMNumZ7+nH2IXzlZttP2hN4DzTnMFitZhd0vAC4Aj2bibs1h6BNnbTWHgHHkD7V00PQrDyIQcQYurwQgWwZ02oOQU+qP/Rn0JbEJPQG/FhmuUtKXWMAAAAASUVORK5CYII=
00:35:03     INFO -  77063 INFO TEST-PASS | /tests/content/events/test/test_bug656379-1.html | Removing the label should have unpressed the button. - expected undefined
00:35:03     INFO -  77064 INFO TEST-END | /tests/content/events/test/test_bug656379-1.html | finished in 301ms
(Reporter)

Comment 1

6 years ago
Created attachment 751743 [details]
actual image from log
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 58

6 years ago
dbaron, can you suggest someone who can look into this?
Flags: needinfo?(dbaron)
No idea.  Did this appear when we started running tests on Windows 8 ("WINNT 6.1"), or was it running on Windows 8 successfully for a while before it started intermittently failing?

If it's the latter, I didn't see anything obvious in the days before it landed; if it's the former, maybe jimm would know?
Component: CSS Parsing and Computation → Event Handling
Flags: needinfo?(dbaron)
(Reporter)

Comment 60

6 years ago
We've been running tests on Win8 since mid-March, so it appears that this is a legit regression.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
bz fixed bug 656379 and presumably wrote this test case. Perhaps he can shed some light on this. As Boris' status says that he is away until Aug 19, pinging jst to see if he has any other suggestions for someone to start looking into this.

I also see bug 475156 and bug 482935 listed in comment 8. These bugs seem pretty different and are only listed in this one comment so this may be a red herring.
Flags: needinfo?(jst)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

6 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

6 years ago
Flags: needinfo?(bugs)
Comment hidden (Treeherder Robot)
bz could likely help out here as well, as/if needed.
Flags: needinfo?(jst)
Flags: needinfo?(bzbarsky)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I didn't actually write this testcase.  mstange did, for bug 426082.  I just copied it...  and then Matt heavily modified it for bug 539356.

In any case, is the issue perhaps that we're ending up shapshotting before we paint?  e.g. would making executeTests use requestAnimationFrame instead of executeSoon help?
Flags: needinfo?(bzbarsky) → needinfo?(matt.woodrow)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I just moved the test to run in its own window, it shouldn't have affected how it works.

We're using MozAfterPaint to ensure that we've painted before the snapshot is taken, so we should be fine there at least.
Flags: needinfo?(matt.woodrow)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
These are all failures in PGO builds, whatever that means.
Whiteboard: [pgo]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Olli, can you please dig in here. We need someone to own this, I'm hoping that can be out. If not, please let me know. Thanks.
Assignee: nobody → bugs
Comment hidden (Treeherder Robot)
(Assignee)

Comment 203

6 years ago
Rather busy right now, but trying to look at this (and few other test failures) next week.
Flags: needinfo?(bugs)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 228

5 years ago
Disabled on Windows for Fx24. We can always re-enable it if an upliftable fix materializes.

https://hg.mozilla.org/releases/mozilla-beta/rev/fc3969695f26
status-firefox24: affected → disabled
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Olli, any updates here?
(Assignee)

Comment 240

5 years ago
It is in my endless todo list. No other updates.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)