If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

allow-pop-ups is not supported in an iframe with sandbox attribute

RESOLVED DUPLICATE of bug 766282

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 766282
4 years ago
4 years ago

People

(Reporter: Andrew S, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Zune 4.7; MS-RTC LM 8; InfoPath.3)

Steps to reproduce:

<iframe src="myscript.js" sandbox="allow-same-origin allow-scripts allow-popups allow-forms"> </iframe>


Actual results:

The script loaded fine, but can't launch new windows or pop ups


Expected results:

Pop ups should be allowed (this is part of the HTML5 spec and supported by Chrome and IE10)
Hello, the developers are already taking care of the implementation of this directive in bug 766282, so I'm marking this as a duplicate.
Thank you for your report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766282
You need to log in before you can comment on or make changes to this bug.