Last Comment Bug 874205 - Unprefix transition styles
: Unprefix transition styles
Status: RESOLVED FIXED
[mentor=margaret][lang=css][good firs...
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 24
Assigned To: Nicolas Carlo [:nickecarlo]
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 13:52 PDT by :Margaret Leibovic
Modified: 2013-05-30 09:13 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Unprefixed the transitions in CSS (2.53 KB, patch)
2013-05-23 04:34 PDT, Nicolas Carlo [:nickecarlo]
margaret.leibovic: review+
Details | Diff | Splinter Review

Description :Margaret Leibovic 2013-05-20 13:52:00 PDT
Transitions were unprefixed in Fx16:
https://developer.mozilla.org/en-US/docs/Web/CSS/transition#Browser_compatibility

Let's update our CSS accordingly.
Comment 1 :Margaret Leibovic 2013-05-20 13:52:52 PDT
Here's a quick search of all the places we use -moz-transition:
http://mxr.mozilla.org/mozilla-central/search?find=/mobile/android/&string=moz-transition
Comment 2 Nicolas Carlo [:nickecarlo] 2013-05-20 15:25:36 PDT
Hey Margaret,

Can I work on this? As far as I understand, I would just need to replace transitions prefixed as "-moz-transitions" to "transitions" as per the first link, is that correct?
Comment 3 :Margaret Leibovic 2013-05-20 16:01:53 PDT
(In reply to Nicolas Carlo from comment #2)
> Hey Margaret,
> 
> Can I work on this? As far as I understand, I would just need to replace
> transitions prefixed as "-moz-transitions" to "transitions" as per the first
> link, is that correct?

Yep, that's right, you should just strip the "-moz-" from the transition property declarations. To make sure nothing's gone awry, you should make a build and play around with the places where we use these transitions, which are HTML5 video controls (touchcontrols.css) and reader mode (aboutReader.css).
Comment 4 Nicolas Carlo [:nickecarlo] 2013-05-21 18:10:35 PDT
Thanks for giving me a shot Margaret. I apologize for not starting on this sooner. I had been having a lot of trouble just building and deploying Fennec as is. I just got it working on my phone so I will start refactoring the code, as per the documentation suggested, tomorrow.

I will probably have a lot of questions still (especially about how to make patches and how to attach them to bugs) so I'll ask them, as they come, in the room (#mobile).
Comment 5 Shashank VRSN Sabniveesu 2013-05-21 20:02:35 PDT
Then, what about the compatibility for pages that implemented "moz-transition" earlier?
Comment 6 :Margaret Leibovic 2013-05-22 11:23:54 PDT
(In reply to shashank16392 from comment #5)
> Then, what about the compatibility for pages that implemented
> "moz-transition" earlier?

I'm afraid I don't understand this question. This change is for CSS styles that are part of the Firefox frontend code, so they only need to work with the version of gecko they're shipped with.
Comment 7 Nicolas Carlo [:nickecarlo] 2013-05-23 04:34:49 PDT
Created attachment 753222 [details] [diff] [review]
Unprefixed the transitions in CSS
Comment 8 :Margaret Leibovic 2013-05-23 10:37:53 PDT
Comment on attachment 753222 [details] [diff] [review]
Unprefixed the transitions in CSS

Looks great, thanks!
Comment 9 :Margaret Leibovic 2013-05-23 10:39:18 PDT
I'm marking this bug as checkin-needed, so someone will come along and land your patch for you.

If you're looking for another bug to tackle, you may want to try out bug 872003, since it deals with the same code.
Comment 10 Nicolas Carlo [:nickecarlo] 2013-05-23 10:48:00 PDT
(In reply to :Margaret Leibovic from comment #9)
> I'm marking this bug as checkin-needed, so someone will come along and land
> your patch for you.
> 
> If you're looking for another bug to tackle, you may want to try out bug
> 872003, since it deals with the same code.

Awesome. Thank you very much. I'll leave a comment about bug 872003 on its page.
Comment 12 Ryan VanderMeulen [:RyanVM] 2013-05-30 09:13:23 PDT
https://hg.mozilla.org/mozilla-central/rev/4ac719409352

Note You need to log in before you can comment on or make changes to this bug.