<input type=file> has unreadable text on dark/black background now

RESOLVED FIXED in Firefox 22

Status

()

Core
Layout: Form Controls
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: j.j., Assigned: mounir)

Tracking

({regression, testcase})

24 Branch
mozilla24
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox21 unaffected, firefox22 verified, firefox23 fixed, firefox24 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
See attachment 180720 [details]: Text on input field is not readable (black on black)
(Reporter)

Comment 1

5 years ago
To the very least the color should be inherited.
See https://bugs.webkit.org/show_bug.cgi?id=67368

Compare upcoming testcase with WebKit/Chrome
Keywords: testcase
(Reporter)

Comment 2

5 years ago
Created attachment 752502 [details]
testcase
(Assignee)

Comment 3

5 years ago
Created attachment 752777 [details] [diff] [review]
Patch

Nice catch, thanks :)
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Attachment #752777 - Flags: review?(bzbarsky)
(Assignee)

Comment 4

5 years ago
Try: https://tbpl.mozilla.org/?tree=Try&rev=bced1c25b398
Comment on attachment 752777 [details] [diff] [review]
Patch

r=me
Attachment #752777 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 6

5 years ago
Thank you for this quick review Boris.

https://hg.mozilla.org/integration/mozilla-inbound/rev/18f85a091e65
Flags: in-testsuite+
Target Milestone: --- → mozilla24
(Assignee)

Comment 7

5 years ago
Comment on attachment 752777 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 874600
User impact if declined: some text might be hardly readable but this bug is affecting old versions of Webkit (Safari 5 and multiple versions of Safari Mobile).
Testing completed (on m-c, etc.): automated tests
Risk to taking this patch (and alternatives if risky): the risk is very low, the benefit isn't high too (given that it's only a disagreement, not terrible) but given that there is barely no risk and that the patch is very small and affects limited part of the code (one CSS line), it seems to me worth to take this patch.
Attachment #752777 - Flags: approval-mozilla-beta?
Attachment #752777 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
(In reply to Mounir Lamouri (:mounir) from comment #7)
> Comment on attachment 752777 [details] [diff] [review]
> Patch
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): bug 874600

I meant bug 52500.
(Reporter)

Comment 9

5 years ago
(In reply to Mounir Lamouri (:mounir) from comment #7)
> User impact if declined: some text might be hardly readable but this bug is
> affecting old versions of Webkit (Safari 5 and multiple versions of Safari
> Mobile).

... but people work around it with -webkit- pseudo-elements
https://hg.mozilla.org/mozilla-central/rev/18f85a091e65
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #752777 - Flags: approval-mozilla-beta?
Attachment #752777 - Flags: approval-mozilla-beta+
Attachment #752777 - Flags: approval-mozilla-aurora?
Attachment #752777 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/7254baf1c150
https://hg.mozilla.org/releases/mozilla-beta/rev/681cb8fbd527
status-firefox21: --- → unaffected
status-firefox22: --- → fixed
status-firefox23: --- → fixed
status-firefox24: --- → fixed
Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0
Build ID: 20130528181031

Verified the fix on latest Firefox 22 beta 3 builds.
status-firefox22: fixed → verified
(Reporter)

Updated

5 years ago
Depends on: 890252
You need to log in before you can comment on or make changes to this bug.