If you have the same number for 2 different contacts, dialer will always connect you through the last created contact.

RESOLVED DUPLICATE of bug 1044028

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1044028
5 years ago
4 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18-v1.0.1 affected)

Details

## Environment :
"mozilla-central" path="gecko" revision="4ac6c72b06c8"
"gecko" revision="94badf2c3afdd2d4b8c1c658f4750881bca41e56"
"gaia.git" revision="5b3ab620547ba72cfc91cb786c0d79740a645cc9"
Build ID: 2013-05-21-03-06-53
MC/master build
Unagi

1. create a contact with a number
2. create a new contact with the same number
3. using contacts, select the details of the first contact that has the same number within the list and select the number to dial

Expected: contact picture of the first listed contact.
Actual: contact picture of the second listed contact.

Note:
1. this occurs in 1.1 as well.
2. If it's an office or if it's a home phone with multiple people this could occur.
Blocks: 1036516
I don't think we have a way to know what contact a phone number should be associated with when selecting from multiple that have that number. The activity that gets dispatched for dialing only contains the number; we match it with the contact manually from the callscreen.
Although this was filed earlier, I'm gonna mark it as duplicate because bug 1044028 contains more information on how to fix this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1044028
You need to log in before you can comment on or make changes to this bug.