The default bug view has changed. See this FAQ.

Hide new options in Notifications preference pane when the old alert is selected

RESOLVED FIXED in seamonkey2.21

Status

SeaMonkey
Preferences
--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rsx11m, Assigned: rsx11m)

Tracking

Trunk
seamonkey2.21

SeaMonkey Tracking Flags

(seamonkey2.19 unaffected, seamonkey2.20 fixed, seamonkey2.21 fixed)

Details

Attachments

(1 attachment)

1.65 KB, patch
Ian Neal
: review+
neil@parkwaycc.co.uk
: ui-review+
Details | Diff | Splinter Review
(Assignee)

Description

4 years ago
(Quoting rsx11m from bug 840474 comment #19)
> Note that bug 856454 will provide a UI for the associated preferences in the
> Notifications pane with SeaMonkey 2.20; if the new alert remains off until
> then, those will have to be hidden to avoid user confusion.
> 
> If mail.biff.show_new_alert will stay even after the new alert if finalized,
> it may be a good idea either way to let visibility of those prefs depend on
> its value.
(Assignee)

Comment 1

4 years ago
Created attachment 752766 [details] [diff] [review]
Proposed patch

This is the least intrusive way to make the additional options hide when the new alert is switched off, thus the UI should be safe for further releases shipped with the old alert selected by default.

It should also be easy to be backed out again if the old code ever gets removed (restricted to a single block of code in a single file and easily searchable by the preference name). As written, an exception is thrown in Startup() if the pref does no longer exist, thus it should be easily discoverable if missed.

Sure, it would be nicer to combine the checkboxes in a vbox and hide that box rather than the individual prefs, but that would imply changes in the XUL part and may result in a redundant vbox if mail.biff.show_new_alert gets removed.

No conflict with bug 872133 attachment 749385 [details] [diff] [review], thus both patches can be reviewed and pushed independently.
Attachment #752766 - Flags: ui-review?(neil)
Attachment #752766 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 2

4 years ago
BTW: alerts.totalOpenTime should apply also for the old notifications, thus I'm not touching it (and it would be tricky string-wise anyway).

Updated

4 years ago
Attachment #752766 - Flags: ui-review?(neil) → ui-review+
(Assignee)

Updated

4 years ago
Summary: Hide new options in Notifications pref pane when the old alert is selected → Hide new options in Notifications preference pane when the old alert is selected

Updated

4 years ago
Attachment #752766 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

4 years ago
Thanks for the reviews, push for comm-central please.
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/bdb8c1fa7c49
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.21
(Assignee)

Comment 5

4 years ago
Comment on attachment 752766 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): Follow-up fix to bug 856454
User impact if declined: SeaMonkey 2.20 would have a different behavior / UX
Testing completed (on m-c, etc.): tested and works fine with 2.20
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none
Attachment #752766 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #752766 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Whiteboard: [c-n: comm-aurora]
https://hg.mozilla.org/releases/comm-aurora/rev/7bc2fd64ec45
status-seamonkey2.20: affected → fixed
status-seamonkey2.21: --- → fixed
Keywords: checkin-needed
Whiteboard: [c-n: comm-aurora]
You need to log in before you can comment on or make changes to this bug.