Closed Bug 875098 Opened 7 years ago Closed 6 years ago

www.globeandmail.ca is displayed poorly in Browser

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mikeh, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-ca][sitewait][serversniff])

Attachments

(2 files)

The Globe and Mail is Canada's paper of record, and its mobile site shows up horribly in the b2g browser.

STR:
1. open Browser app
2. go to www.globeandmail.ca -- will redirect to m.globeandmail.com

Expected result: display parity with other smartphones.

Observed results: see attached screen shots.
The headlines are all jumbled together, separator lines are missing, and (not shown) photos which should appear left-aligned are all over the place.
They appear to be doing some kind of browser sniffing and sending a "fallback" version for Firefox OS which doesn't work properly.

For example, if I load m.theglobeandmail.com in desktop Firefox the body tag looks like:

<body class="news smartphone other notouch">

and it renders fine.

If I load it in the B2G Simulator, the body tag looks like:

<body class="news fallback other notouch">

There appears to be no CSS rendered and I see a JavaScript error.

I don't think it's just based on UA string because if I spoof my UA string in desktop Firefox I still get the same version, they must be doing some other form of sniffing?
Assignee: nobody → english-other
Component: Gaia::Browser → English Other
Product: Boot2Gecko → Tech Evangelism
As an extra data-point, my BlackBerry (running OS 7.1 which has a WebKit-based browser) renders the m.theglobeandmail.com page properly.
Moving this to Mobile, nobody is really paying attention to these language components (AFAIK).
Assignee: english-other → nobody
Component: English Other → Mobile
Apparently they're doing some server-side detection that fails to recognize Firefox OS devices as mobile:

Selected response headers for Firefox OS:
Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 301
location: http://www.theglobeandmail.com/

Selected response headers for Firefox for Android:
Response for: 'Mozilla/5.0 (Android; Mobile; rv:27.0) Gecko/27.0 Firefox/27.0'
Response Status: 302
location: http://m.theglobeandmail.com/?service=mobile

The suggested fix would be to send Firefox OS to the same location as Firefox for Android.
Whiteboard: [country-ca][contactready][serversniff]
asking a friend.
Trying to contact a Web developer at Globe And Mail
http://twitter.com/MozWebCompat/status/458096030207053825
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-ca][contactready][serversniff] → [country-ca][sitewait][serversniff]
This has been FIXED.
Thanks to the Globe And Mail team.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
So there is a regression. Firefox OS receives again the desktop site.
Let deal with this on https://webcompat.com/issues/1365
instead of here.  I keep here closed.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.