Last Comment Bug 875169 - Crash upon loading a page with a track element
: Crash upon loading a page with a track element
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla24
Assigned To: Rick Eyre (:reyre)
:
Mentors:
Depends on: 833382
Blocks: webvtt 833386
  Show dependency treegraph
 
Reported: 2013-05-22 18:14 PDT by Rick Eyre (:reyre)
Modified: 2013-06-11 18:12 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Back trace (5.02 KB, text/plain)
2013-05-22 18:14 PDT, Rick Eyre (:reyre)
no flags Details
Bug 875169v1 (1.21 KB, patch)
2013-05-22 23:10 PDT, Rick Eyre (:reyre)
bzbarsky: review-
Details | Diff | Splinter Review
Back trace (more complete) (5.35 KB, text/plain)
2013-05-23 00:30 PDT, Rick Eyre (:reyre)
no flags Details
Patch version 2 (32.44 KB, patch)
2013-05-23 19:53 PDT, Rick Eyre (:reyre)
no flags Details | Diff | Splinter Review
Patch version 2 (1.84 KB, text/x-patch)
2013-05-23 19:55 PDT, Rick Eyre (:reyre)
no flags Details
Patch version 2 (1.84 KB, patch)
2013-05-23 19:57 PDT, Rick Eyre (:reyre)
bzbarsky: review+
Details | Diff | Splinter Review

Description Rick Eyre (:reyre) 2013-05-22 18:14:46 PDT
Created attachment 753063 [details]
Back trace

When loading a page with a track element program receives an EXC_BAD_ACCESS error.
Comment 1 Rick Eyre (:reyre) 2013-05-22 23:10:33 PDT
Created attachment 753116 [details] [diff] [review]
Bug 875169v1
Comment 2 Rick Eyre (:reyre) 2013-05-22 23:27:41 PDT
Comment on attachment 753116 [details] [diff] [review]
Bug 875169v1

Actually, this doesn't solve the root problem. Will post back...
Comment 3 Rick Eyre (:reyre) 2013-05-22 23:58:41 PDT
Comment on attachment 753116 [details] [diff] [review]
Bug 875169v1

Actually, this might be a reasonable way of fixing this.
Comment 4 Rick Eyre (:reyre) 2013-05-23 00:30:58 PDT
Created attachment 753135 [details]
Back trace (more complete)
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2013-05-23 07:27:58 PDT
Comment on attachment 753116 [details] [diff] [review]
Bug 875169v1

Please just add overloads of GetSrclang and GetLabel that use nsString& as the outparam and get rid of the DOMString goop in this method altogether.
Comment 6 Rick Eyre (:reyre) 2013-05-23 19:53:50 PDT
Created attachment 753592 [details] [diff] [review]
Patch version 2

- HTMLTrackElement() now has overloaded functions for GetLabel() and GetSrclang() that take nsString&
- HTMLTrackElement::CreateTextTrack() now uses these functions when creating a new TextTrack.
Comment 7 Rick Eyre (:reyre) 2013-05-23 19:55:03 PDT
Created attachment 753593 [details]
Patch version 2

- HTMLTrackElement() now has overloaded functions for GetLabel() and GetSrclang() that take nsString&
- HTMLTrackElement::CreateTextTrack() now uses these functions when creating a new TextTrack.
Comment 8 Rick Eyre (:reyre) 2013-05-23 19:57:03 PDT
Created attachment 753594 [details] [diff] [review]
Patch version 2

Wow... well this should be the right attachment. Sorry about that.
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2013-05-23 20:26:21 PDT
Comment on attachment 753594 [details] [diff] [review]
Patch version 2

r=me.
Comment 10 Rick Eyre (:reyre) 2013-06-10 11:57:53 PDT
https://tbpl.mozilla.org/?tree=Try&rev=e2a478f63c6f
Comment 11 Ralph Giles (:rillian) needinfo me 2013-06-10 13:35:58 PDT
New try push on top of incoming including the patches from bug 833382 and 881432.

https://tbpl.mozilla.org/?tree=Try&rev=81de1fc9d46c
Comment 12 Rick Eyre (:reyre) 2013-06-11 07:12:23 PDT
I've starred most of the ones that I could find bugs on. The only one lest is the reftest crash on OS X.

I've spun up a build to test repeatability: https://tbpl.mozilla.org/?tree=Try&rev=5b34607a261b
Comment 13 Ralph Giles (:rillian) needinfo me 2013-06-11 09:52:31 PDT
Cipc failure from my try in comment #11 isn't repeatable, so looks like we're clean. Let me know when you're ready to land.
Comment 14 Rick Eyre (:reyre) 2013-06-11 10:04:11 PDT
Looks good to me. Land ho!
Comment 15 Ralph Giles (:rillian) needinfo me 2013-06-11 10:20:15 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/fbab527d8a4f
Comment 16 Ryan VanderMeulen [:RyanVM] 2013-06-11 18:12:10 PDT
https://hg.mozilla.org/mozilla-central/rev/fbab527d8a4f

Note You need to log in before you can comment on or make changes to this bug.