If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

|domObject instanceof otherWin.Constructor| should work

RESOLVED DUPLICATE of bug 870423

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 870423
4 years ago
4 years ago

People

(Reporter: bholley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

So, [1] alerts true, and [2] alerts false. Heycam says that he updated the spec in [3] so that instanceof should be scope-agnostic. This is kind of unexpected, since I'd imagine that these two cases would look the same under the hood: we should end up in the compartment of the constructor, with the object being a cross-compartment wrapper. 

[1] http://bit.ly/14Tde2J
[2] http://bit.ly/12XLbxI
[3] http://dev.w3.org/2006/webapi/WebIDL/#es-interface-hasinstance
Oh, this is just bug 870423. /me facepalms
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870423
Wait, why?  There is no sandbox here...
Oh, I see.  The key is having the RHS be a proxy of any kind.... I guess we tested it for cases when the _LHS_ was the proxy, but not the other.  Funtimes.
(In reply to Boris Zbarsky (:bz) from comment #3)
> Oh, I see.  The key is having the RHS be a proxy of any kind

Well, a function proxy.
You need to log in before you can comment on or make changes to this bug.