Future.catch() has the problem of using an EcmaScript reserved name and old browsers will not enjoy that. This is the same probleme with .delete() in IDB. Developers have to do idb['delete']() to be able to have the code parsed (not even executed) in all browsers. Might be a pain if developers have to do that with catch.
'fail', like in the Q library?
Anne, can you give a feedback about this?
This ground has been covered in the spec discussion. ES5 happened, we're gonna use the terms that make the most sense.
Please, keep this bug open until the discussion happened in a public place.
I don't think this is what we want. Do we really want to rename catch() ?
No. (And to address comment 4, this discussion did happen in a public place.)