Page corruption upon second viewing with back button

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Jonathan Abbey, Assigned: karnaze (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010623
BuildID:    2001062306

If you go to the referenced URL, you get a properly displayed page of
accesses to some software I publish.  If you then visit any other page
and go back, you get seemingly random corruption at the bottom of the
page.

Reproducible: Always
Steps to Reproduce:
1.Visit
http://www.arlut.utexas.edu/cgi-bin/log_display.pl?log_name=access&lines=500&grep=gash2
2. Go anywhere else
3. Hit back, then scroll down to the bottom of the page

Actual Results:  Garbage at the bottom of the page

Expected Results:  Redisplay the log page in identical fashion as when it was first
viewed
(Reporter)

Updated

17 years ago
Component: Layout → History: Session
(Reporter)

Comment 1

17 years ago
Additional experimentation shows that viewing the page source for this page
shows the corruption before ever leaving and returning to the page.  Whatever
source the 'view source' function is drawing on is corrupted.
(Reporter)

Comment 2

17 years ago
Okay, yet more investigation shows that the page my CGI is generating is
malformed, with no <HTML><BODY> at the top, but including </BODY></HTML> at
the bottom.  My bad, and I can fix this, but I'm going to leave it as is for
the sake of shaking out Mozilla's behavior on this.

If you'd rather I just go away, I'd understand and will fix my stuff and be
happy.  It does look like Mozilla is doing something unexpected here, though.

Comment 3

17 years ago
It works for me w2k 2001062204 and on linux 2001062406.
The parser should be able to handle missing <html> and <body> tags, so if you
are still seeing this with todays build see if you can make a testcase, or at
least leave one page broken on your server. Also if you could describe what sort
of corruption is happening that would help. Are the </body> and </html> tags
appearing in the view source? What happens if you do a save as (view source goes
through a slightly different path.  Are you capable of looking at the HTTP
headers?  If things are showing up wrong on an initial load (beware of cache)
the problem is probably in networking HTTP.    

Comment 4

17 years ago
If the page length gets shorter, you might be seeing bug 79983. 
(Reporter)

Comment 5

17 years ago
I do see this with the current build (2001062306) on Linux.

The page length gets longer, with a bunch of random garbage extracted
from the contents of the page tacked onto the end.

Doing 'save as' results in a file saved to disk with the corruption.  I
will upload it as an attachment to this bug.
(Reporter)

Comment 6

17 years ago
Created attachment 39876 [details]
HTML 'save as' showing the corruption that I see when viewing and hitting 'back' on the primary URL
(Reporter)

Comment 7

17 years ago
I still see this behavior in today's (2001062406) Linux build, as well.
(Reporter)

Comment 8

17 years ago
I looked at bug 79983, but it looks different enough that I don't recognize it
as being the same bug.  The fact that I can view the CGI output initially
okay, but then see the corruption when I do a 'save as' or a 'view source',
or going to another page and then hitting 'back' makes me think it's happening
someplace else.

Comment 9

17 years ago
I see it as well on both w2k and linux.  I was running with all cache disabled
before, it makes it easier to spot some intemittnet bugs sorry for any confusion
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Reporter)

Comment 10

17 years ago
I am continuing to see this behavior with the latest (2001-07-13 08) linux
trunk build.
(Reporter)

Comment 11

17 years ago
This appears to be fixed in the Linux nightly build of 2001073106.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: chrispetersen → docshell
You need to log in before you can comment on or make changes to this bug.