widget not working in sdk 1.14 but working in online editor

RESOLVED DUPLICATE of bug 851426

Status

RESOLVED DUPLICATE of bug 851426
5 years ago
5 years ago

People

(Reporter: zitalman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 Iceweasel/21.0 (Beta/Release)
Build ID: 20130515112942

Steps to reproduce:

use the "widget" component in SDK 1.14 in iceweasel 21.0 in debian gnu/linux


Actual results:

command: cfx run

result:
error: example: An exception occurred.
TypeError: hiddenWindow.document.documentElement is null
resource://gre/modules/commonjs/sdk/frame/hidden-frame.js 73
Traceback (most recent call last):
  File "resource://gre/modules/NetUtil.jsm", line 140, in 
    aCallback(pipe.inputStream, aStatusCode, aRequest);
  File "resource://gre/modules/commonjs/sdk/net/url.js", line 49, in 
    resolve(data);
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 123, in then
    else result.then(resolved, rejected)
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 55, in effort
    try { return f(options) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 143, in resolve
    while (pending.length) result.then.apply(result, pending.shift())
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 37, in then
    return { then: function then(resolve) { resolve(value) } }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 117, in resolved
    function resolved(value) { deferred.resolve(resolve(value)) }
  File "resource://gre/modules/commonjs/sdk/core/promise.js", line 55, in effort
    try { return f(options) }
  File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 90, in onLocalizationReady
    run(options);
  File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 134, in run
    quit: exit
  File "resource://jid1-2hf32uvcxi5n7q-at-jetpack/forocoches/lib/main.js", line 15, in exports.main
    require("sdk/widget").Widget(
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 133, in options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/sdk/widget.js", line 39, in 
    const panels = require("./panel");
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 133, in options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/sdk/panel.js", line 17, in 
    const { Symbiont } = require('./content/content');
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 133, in options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/sdk/content/content.js", line 13, in 
    exports.Symbiont = require('./symbiont').Symbiont;
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 133, in options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/sdk/content/symbiont.js", line 14, in 
    const hiddenFrames = require('../frame/hidden-frame');
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 133, in options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/sdk/frame/hidden-frame.js", line 81, in 
    var hostFrame = makeHostFrame();
  File "resource://gre/modules/commonjs/sdk/frame/hidden-frame.js", line 73, in makeHostFrame
    namespaceURI: hiddenWindow.document.documentElement.namespaceURI,
^L^CTraceback (most recent call last):
  File "/home/iban/Downloads/addon-sdk-1.14/bin/cfx", line 33, in <module>
    cuddlefish.run()
  File "/home/iban/Downloads/addon-sdk-1.14/python-lib/cuddlefish/__init__.py", line 928, in run
    bundle_sdk=options.bundle_sdk)
  File "/addon-sdk-1.14/python-lib/cuddlefish/runner.py", line 720, in run_app
    time.sleep(0.05)
KeyboardInterrupt



Expected results:

copy pasting the code to:

https://builder.addons.mozilla.org

online editor, works fine

Updated

5 years ago
Component: Untriaged → General
Product: Firefox → Add-on SDK
Version: 21 Branch → unspecified
Can you link to your code on Builder or elsewhere so we can look at it?
Flags: needinfo?(zitalman)
(Reporter)

Comment 2

5 years ago
var Widget = require("sdk/widget").Widget;
new Widget(
{
	id: 'widget-1',
	label: 'label',
	contentURL: 'favicon_uri'
});

// the same code in ubuntu 13.04 firefox 21.0 works fine
Flags: needinfo?(zitalman)
Matteo, I recall you saying that things were still broken in iceweasel, was there a specific bug about that and does this match it?
Flags: needinfo?(zer0)
Yes, I mentioned to you the bug 851426, and I suggested that should be uplifted as the bug 855651: in order to have rebranded products working we need both the fixes of bug 855651 and bug 851426.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(zer0)
Resolution: --- → DUPLICATE
Duplicate of bug: 851426
You need to log in before you can comment on or make changes to this bug.