Closed Bug 875469 Opened 7 years ago Closed 7 years ago

XUL filepicker's checkbox to show hidden files and directories has bogus left align attribute

Categories

(Toolkit :: XUL Widgets, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24

People

(Reporter: neil, Assigned: neil)

Details

Attachments

(1 file)

Steps to reproduce problem:
1. Build on Linux
2. Set ui.allow_platform_file_picker to false
3. Open or save a file

Expected result: checkbox has theme's default rendering.

Actual result: checkbox and its text are misaligned.
Attached patch Proposed patchSplinter Review
Seems to be a bogus align="left" attribute. (Not sure how that's even achieving vertical alignment...)

Just noticed that the problem is particularly bad if your fonts are large enough to make the text overflow to a second line (or you can resize the dialog).

Don't know who a good reviewer for this is so defaulting to module owner for now.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #753454 - Flags: review?(dtownsend+bugmail)
Attachment #753454 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/mozilla-central/rev/59054375b00b
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.