Fix ANGLE compilation on NetBSD and DragonFly

RESOLVED FIXED in mozilla33

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: François Tigeot, Unassigned)

Tracking

Trunk
mozilla33
x86_64
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; DragonFly x86_64; rv:20.0) Gecko/20100101 SeaMonkey/2.17 (Beta/Release)
Build ID: 20130513175155

Steps to reproduce:

I tried to build various mozilla products on DragonFly.


Actual results:

Compilation failed with many of these errors:
./src/compiler/osinclude.h:22:2: error: #error Unsupported platform.


Expected results:

Builds should have succeeded.
(Reporter)

Comment 1

5 years ago
Created attachment 753502 [details] [diff] [review]
Compilation fix for NetBSD and DragonFly
(Reporter)

Comment 2

5 years ago
NetBSD suffers from the same issue, the attached patch fix ANGLE compilation for both NetBSD and DragonFly.
It would be good to get this upstream.
Component: Graphics → Canvas: WebGL
(Reporter)

Updated

5 years ago
Attachment #753502 - Flags: review?(bjacob)
Attachment #753502 - Flags: review?(bjacob) → review+
Wait, this patch is against a .orig file, you want to fix that ;-)

Also, this needs a combination of 1) upstreaming as mentioned in comment 3, and 2) having a local gfx/angle/*.patch recorded and mentioned in gfx/angle/README.mozilla.
(Reporter)

Comment 5

5 years ago
Created attachment 753720 [details] [diff] [review]
Fix for compilation on NetBSD and DragonFly (proper changeset file)
(Reporter)

Comment 6

5 years ago
I initially added a wrong patch file, sorry about that :-/

For the rest, I thought Mozilla was the upstream since this code is present in the mozilla-central repository and many of the various tarballs your organization distributes.

If Mozilla is not the real upstream and doesn't maintain this code, there is no point in trying to integrate patches here, especially if they will stay as patches.

I'll go bother the ANGLE developers, whoever they are ;-)
Mozilla is not the upstream; the upstream is https://code.google.com/p/angleproject/ .

The reason why this is in Mozilla-central is that we need to use very specific versions of ANGLE with a few specific patches. Likewise, WebKit (or Chromium, not sure) has its own copy of ANGLE.

So in the long term, all what matters is that this be upstream in ANGLE, but if you want this fixed immediately in Firefox, without waiting for the next time that we sync with upstream, then you may still want this checked into mozilla-central.
(Reporter)

Comment 8

5 years ago
Firefox is already patched locally in the dports and pkgsrc packaging systems; adding local patches to the Mozilla repositories would only increase your maintenance burden.

I have opened a new issue on https://code.google.com/p/angleproject/ with the same fix.

Marking as resolved invalid since I reported this particular problem to the wrong organization.
Sorry for the time wasted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(In reply to François Tigeot from comment #8)
> Firefox is already patched locally in the dports and pkgsrc packaging
> systems; adding local patches to the Mozilla repositories would only
> increase your maintenance burden.

It would not, because these local patches are already applied in the tree.

But I'm not complaining at all if you're OK with just upstreaming this.

Thanks!

Comment 10

4 years ago
Recent ANGLE update brought the fix from upstream.
Depends on: 1010371
Resolution: INVALID → FIXED
Target Milestone: --- → mozilla33
Awesome. :)
You need to log in before you can comment on or make changes to this bug.