Crash [@ JS_DumpPCCounts] or Assertion failure: isScriptSource(), at jsscript.h or Assertion failure: is<T>(), at jsobj.h with -D and gcslice

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86_64
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 753509 [details]
stack

The upcoming testcase asserts the following js shell on m-c with --ion-eager -D at Assertion failure: isScriptSource(), at jsscript.h

https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1369309413/jsshell-mac64.zip

A variant crashes at DumpPCCounts.

This appeared this morning, assuming also related to bug 870052.
Flags: needinfo?(bhackett1024)
(Reporter)

Updated

6 years ago
Summary: Crash [@ JS_DumpPCCounts] or Assertion failure: isScriptSource(), at jsscript.h → Crash [@ JS_DumpPCCounts] or Assertion failure: isScriptSource(), at jsscript.h with -D and gcslice
Can you bisect this?  I doubt that 870052 caused this.
Flags: needinfo?(bhackett1024)
(Reporter)

Comment 4

6 years ago
(In reply to Brian Hackett (:bhackett) from comment #3)
> Can you bisect this?  I doubt that 870052 caused this.

Nope, I couldn't reproduce on a local build. :(

This morning's pushlog is likely:

https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=63b006573c65

What changeset could have caused this, any idea?
No longer blocks: 870052
Flags: needinfo?(bhackett1024)
Looking at the assertion I would suspect bug 637572, which landed yesterday, but it would be good to confirm / have a reproducible testcase.
Flags: needinfo?(bhackett1024)
(Reporter)

Comment 6

6 years ago
Thanks Brian!

Testcases are available and reproducible with the binaries from the link I provided in comment 0.

Jim, this may be related to debugger stuff, do you think this is the case?
Blocks: 637572
Flags: needinfo?(jimb)
(Reporter)

Comment 7

6 years ago
I've also sent the testcases to Jim and Eddy via email.
(Reporter)

Comment 9

5 years ago
I could reproduce locally now without --enable-more-deterministic, and without --enable-threadsafe:

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   http://hg.mozilla.org/mozilla-central/rev/88016f09b0f4
user:        Eddy Bruel
date:        Wed May 22 16:23:07 2013 -0700
summary:     Bug 637572 - Use ScriptSourceObject instead of ScriptSource; r=jimb
Flags: needinfo?(ejpbruel)

Comment 10

5 years ago
At the moment I'm focussed on bug 797627, but when that's been settled I'll finish up Debugger.Source, and address this.
Flags: needinfo?(jimb)
(Reporter)

Comment 11

5 years ago
Created attachment 766176 [details]
possibly related stack

Assertion failure: is<T>(), at jsobj.h may be a possibly related stack, but the testcase for this was pretty unreliable.
(Reporter)

Updated

5 years ago
Summary: Crash [@ JS_DumpPCCounts] or Assertion failure: isScriptSource(), at jsscript.h with -D and gcslice → Crash [@ JS_DumpPCCounts] or Assertion failure: isScriptSource(), at jsscript.h or Assertion failure: is<T>(), at jsobj.h with -D and gcslice
(Reporter)

Updated

5 years ago
Assignee: general → nobody
QA Contact: general
(Reporter)

Comment 12

5 years ago
(In reply to Jim Blandy :jimb from comment #10)
> At the moment I'm focussed on bug 797627, but when that's been settled I'll
> finish up Debugger.Source, and address this.

Bug 797627 has been resolved - I'm not sure where the Debugger.Source bug is, but setting needinfo for an update after 8 months. :)
Flags: needinfo?(jimb)

Comment 13

5 years ago
Can you still reproduce this? We've fixed a number of bugs in that area since June.
Flags: needinfo?(jimb)
(Reporter)

Comment 14

5 years ago
I just retested. Good point - I don't seem to reproduce anymore. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(ejpbruel)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.