Customize diff type for Bugzilla confirmation mails

RESOLVED DUPLICATE of bug 65477

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 65477
17 years ago
6 years ago

People

(Reporter: miikl, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
I receive confirmation mails when someone changes the state of a Mozilla bug I
reported or voted for.  The confirmation mails seem to show what changed between
versions with some kind of side-by-side diff.

These side-by-side / 2 column diffs do not display correctly (they don't line
up) in my MUA (Yahoo Mail web interface), perhaps due to wrapping.  I would like
to be able to specify a different diff type (e.g. context diff or unified diff)
for confirmation mails.

There does not seem to be any such option currently on the "prefs" page.

The relevant component would be whatever component of Bugzilla handles the diffs
and mailing.  I suspect it is Bugzilla Helper, but am not entirely sure.
No, it isn't :-)

The diffs Bugzilla produces are not produced by the diff program, but 
home-rolled. We just ripped out the oldemailtech which did other sorts of diff, 
because it was a pain in the bum.

However, we might be able to arrange for "HTML" messages surrounded by <PRE>. 
Would that help?

Gerv
Assignee: gervase.markham → tara
Component: Bugzilla Helper → Bugzilla
OS: Windows NT → All
Hardware: PC → All
Summary: [RFE] customize diff type for Bugzilla confirmation mails → Customize diff type for Bugzilla confirmation mails


*** This bug has been marked as a duplicate of 65477 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
No, I was just hoping there might be a relatively painless way to customize the 
diff type (thinking that perhaps the output may have been produced by "diff"), 
preferably some method of displaying the changes in a single-column format.  It 
sounds like what I wanted can't easily be done, so don't worry about it.

For what it's worth, I am viewing the mail in fixed-width mode, wrapping at the 
72nd column, as I suspect many who are viewing their mail on a text-console, so 
I hope the confirmation mails will continue to be rendered well under such 
environments.  The last few mails from this bug have actually wrapped quite 
well. :-/

Comment 4

17 years ago
The side-by-side format for certain fields wrap at column 77.  This is
considered to be the "norm" as most text consols are 80 columns wide.

I haven't played with Yahoo! mail's prefs recently, but isn't it possible to
view it with an 80 column wrap?

Of course, for most webmail apps (and many other mail programs) an HTML pref
would be a nicer solution.
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.