exe file handling is completely broken since landing of Bug 862088

VERIFIED FIXED in Firefox 24

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: alice0775, Assigned: rillian)

Tracking

({regression})

24 Branch
mozilla24
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24+ verified)

Details

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/df526497d949
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130524 Firefox/24.0 ID:20130524031033

STR #1
1. Open http://www.mozilla.org/en-US/
2. Click Green Download Button

STR #2
1. Enter http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/firefox-24.0a1.en-US.win32.installer.exe in Location Bar and Keypress ENTER

STR #3
1. Open http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
2. Right click on firefox-24.0a1.en-US.win32.installer.exe
3. Choose Save Link As..

Actual Results:
Nightly try to play the exe file as mp3 .
Save as type is "MP3 Format Sound(*.exe)" in Save As dialog.

Expected Results:
Opening foobar.exe dialog should pop up.
Save as type should be "Binary File(*.exe;*.com;*.bin)" in Save As dialog.
PS
I was surprised at a fact that Mozilla did not provide an automatic test for such basic function...
Summary: exe file handlig is complementary broken since landing of Bug 862088 → exe file handling is completely broken since landing of Bug 862088
Also I can confirm the problem in ubuntu 12.04LTS.
http://hg.mozilla.org/mozilla-central/rev/df526497d949
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130524 Firefox/24.0 ID:20130524031033
OS: Windows 7 → All
Assignee: nobody → giles
Component: General → Video/Audio
I have the same problem , Nightly 24.0a1
Duplicate of this bug: 876065
Duplicate of this bug: 876131
Duplicate of this bug: 876132
Bug 862088 backed out.
https://hg.mozilla.org/mozilla-central/rev/218785bab4bd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Duplicate of this bug: 876141
Verified fixed FF 24b10, 26.0a1 (2013-09-09)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.