Closed Bug 87588 Opened 20 years ago Closed 20 years ago

Dialog "enter password" blocks other mozilla window

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 65521

People

(Reporter: tux, Assigned: asa)

References

()

Details

I have two mozilla windows opened. One with mail, second where I typed url of
passworded page and a "enter password" dialog appeared.

Problem is that when there is some dialog like "enter password" activated, I
can't do anything in all other mozilla windows, they are blocked. I suppose that
only the one window which is asking for password should be blocked from
receiving input, not the others. (I was unable to copy&paste the username and
then the password from the email in another window to the dialog, as it was
disabled)

There are more similarly annoying situations where i need to do anything in
other mozilla window before responding to the dialog.

I suppose that the same bug will probably affect other dialogs too
(acceps/refuse certificate in https, allow/refuse cookie/image, some other
password/forms manager dialogs, etc ...)
Duplicate of "modal dialogs should only freeze parent window (not all windows)"

*** This bug has been marked as a duplicate of 65521 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.