Closed Bug 876030 Opened 9 years ago Closed 9 years ago

Defect - The tile selection app bar should disappear if the user navigates to a page

Categories

(Firefox for Metro Graveyard :: App Bar, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 24

People

(Reporter: TimAbraldes, Assigned: jimm)

References

Details

(Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=1)

Attachments

(2 files)

STR:
  1) Open a tab
  2) Select one or multiple tiles
  3) Note that the tile context app bar has appeared
  4) Tap a tile to navigate to that page
  5) Note that the tile context app bar is still visible, even though it no longer makes sense
Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=0
QA Contact: jbecerra
Priority: -- → P1
QA Contact: jbecerra
Duplicate of this bug: 876062
This was really confusing at first glance since we now have two app bars, the nav bar and the context app bar. So I renamed 'appbar' to 'navbar' to clear up the confusion.
Assignee: nobody → jmathies
Attachment #755416 - Flags: review?(sfoster)
Attached patch bug fixSplinter Review
The bug fix.
Attachment #755417 - Flags: review?(sfoster)
Depends on: 857437
Blocks: metrov1it8
No longer blocks: metrov1defect&change
QA Contact: jbecerra
Whiteboard: feature=defect c=firefox_start u=metro_firefox_user p=0 → feature=defect c=firefox_start u=metro_firefox_user p=1
Status: NEW → ASSIGNED
Blocks: 877352
Comment on attachment 755417 [details] [diff] [review]
bug fix

Review of attachment 755417 [details] [diff] [review]:
-----------------------------------------------------------------

Yep
Attachment #755417 - Flags: review?(sfoster) → review+
Comment on attachment 755416 [details] [diff] [review]
rename 'appbar' to 'navbar'

Review of attachment 755416 [details] [diff] [review]:
-----------------------------------------------------------------

The ContentAreaObserver patch looks fine but needs some changes from the parent bug to apply. All else works, clean test run. Thanks for clearing this up it was a source of ongoing confusion.
Attachment #755416 - Flags: review?(sfoster) → review+
https://hg.mozilla.org/mozilla-central/rev/a14649f8410c
https://hg.mozilla.org/mozilla-central/rev/0f0f28089ee0
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20130610 Firefox/24.0

Verified the fix on latest Nightly build: the context appbar is successfully dismissed when a page is loaded.
Status: RESOLVED → VERIFIED
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130816030205
Built from http://hg.mozilla.org/mozilla-central/rev/1ed5a88cd4d0

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.