Closed Bug 876068 Opened 7 years ago Closed 6 years ago

b2g Windows desktop builds mostly fail, after a "C:\Tools\sdks\v7.0\include\winnt.h(135) : fatal error C1189: #error : "No Target Architecture""

Categories

(Firefox OS Graveyard :: GonkIntegration, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

(firefox25 unaffected, firefox26 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
1.2 FC (16sep)
Tracking Status
firefox25 --- unaffected
firefox26 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: philor, Assigned: mossop)

References

Details

(Keywords: intermittent-failure)

Maybe this is bustage from something that landed on inbound Wednesday or Thursday, maybe it's from something that landed outside of inbound, or a buildbot change, or a need for clobbering but clobbering is busted - it looked like outside of inbound since retriggering on the last green one before it started came back red, then it looked like clobbering since one in the middle of a run of red was green and after I clobbered and retriggered things were green, but then they became mostly red again. Dunno.

https://tbpl.mozilla.org/php/getParsedLog.php?id=23385473&tree=Mozilla-Inbound
b2g_mozilla-inbound_win32_gecko build on 2013-05-24 16:56:45 PDT for push 4aa62afd5aa9
slave: w64-ix-slave109

17:54:04     INFO -  e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\build\obj-firefox\b2g\locales\Makefile:158:0: command 'MACOSX_DEPLOYMENT_TARGET= compare-locales -m e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\.\build\obj-firefox\merged e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/b2g/locales/l10n.ini e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\.\gecko-l10n es-ES' failed, return code 126
17:54:04    ERROR - Return code: 2
...
17:54:21     INFO -  e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\build\config\rules.mk:1141:0$ e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/obj-firefox/_virtualenv/Scripts/python.exe -O e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/build/cl.py cl -FonsBrowserApp.obj -c   -DENABLE_MARIONETTE=1 -DXPCOM_GLUE -DNO_NSPR_10_SUPPORT -DAPP_NAME=b2g -DAPP_VERSION=24.0a1 -DMOZ_UPDATER=  -DMOZ_SOURCE_REPO="http://hg.mozilla.org/integration/mozilla-inbound" -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/toolkit/xre -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/xpcom/base -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/xpcom/build -I../../build -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/b2g/app -I. -I../../dist/include  -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/obj-firefox/dist/include/nspr -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/obj-firefox/dist/include/nss        -wd4099 -DMOZ_ENABLE_JS_DUMP -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4251 -wd4244 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy -MD            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/b2g/app/nsBrowserApp.cpp
17:54:22     INFO -  nsBrowserApp.cpp
17:54:22     INFO -  C:\Tools\sdks\v7.0\include\winnt.h(135) : fatal error C1189: #error :  "No Target Architecture"
17:54:22     INFO -  e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\build\config\rules.mk:1141:0: command 'e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/obj-firefox/_virtualenv/Scripts/python.exe -O e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/build/cl.py cl -FonsBrowserApp.obj -c   -DENABLE_MARIONETTE=1 -DXPCOM_GLUE -DNO_NSPR_10_SUPPORT -DAPP_NAME=b2g -DAPP_VERSION=24.0a1 -DMOZ_UPDATER=  -DMOZ_SOURCE_REPO="http://hg.mozilla.org/integration/mozilla-inbound" -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/toolkit/xre -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/xpcom/base -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/xpcom/build -I../../build -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/b2g/app -I. -I../../dist/include  -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/obj-firefox/dist/include/nspr -Ie:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/obj-firefox/dist/include/nss        -wd4099 -DMOZ_ENABLE_JS_DUMP -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4251 -wd4244 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy -MD            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/b2g/app/nsBrowserApp.cpp' failed, return code 2
17:54:22     INFO -  e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\build\config\rules.mk:680:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-in-w32_g-0000000000000000000/build/build/pymake/pymake/../make.py libs' failed, return code 2
17:54:22    ERROR - Return code: 2
17:54:22    FATAL - Halting on failure while running C:\mozilla-build\python27\python.exe e:\builds\moz2_slave\m-in-w32_g-0000000000000000000\./build/build/pymake/make.py -C app
https://tbpl.mozilla.org/php/getParsedLog.php?id=23391236&tree=Mozilla-Inbound

Clobbering again, because I'm getting bored with seeing these.
So we're all agreed, then? Just stop even trying to build b2g desktop on Windows?
Only for very nearly the end - it can't be all that difficult to shut them off, I should be able to write the patch.

https://tbpl.mozilla.org/php/getParsedLog.php?id=23633262&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23633087&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=23639456&tree=Birch
https://tbpl.mozilla.org/php/getParsedLog.php?id=23639557&tree=Birch

This needs attention ASAP. This will block the Gaia ui-test work. Ted, can you take a look since none of the other build peers are around right now?
Severity: normal → critical
Flags: needinfo?(ted)
We have no plans to use the per-commit b2g desktop builds on Windows for automation; I can't say whether anyone uses the nightlies, however.
I've seen this locally while building a toy project, it was due to including headers in the wrong order:
http://stackoverflow.com/questions/4845198/fatal-error-no-target-architecture-in-visual-studio-2010

I'm not sure why we'd be seeing this intermittently on our b2g builds.
We see it intermittently because we intermittently do dep builds - the periods where I'm not starring it constantly are the periods where we either blind-clobbered everything, or I got sick of this and clobbered just it, or we got a slave without an existing objdir.
https://tbpl.mozilla.org/php/getParsedLog.php?id=23688541&tree=Mozilla-Inbound

Or maybe it is an intermittent race, that's just neatly ducked by slowing things down with a clobber, I'm not entirely sure.
No longer blocks: 879370
Depends on: 879370
Myk, Alex, in the engineering call today they talked about turning off b2g desktop builds on windows because of this. That seems likely harmful to simulator, is that right?
Flags: needinfo?(poirot.alex)
Flags: needinfo?(myk)
Assignee: nobody → dtownsend+bugmail
https://tbpl.mozilla.org/php/getParsedLog.php?id=23782017&tree=Mozilla-Inbound

Bug 879370 was the "without all the horrible noise of starring" bug that you were looking for.
(In reply to Dave Townsend (:Mossop) from comment #79)
> Myk, Alex, in the engineering call today they talked about turning off b2g
> desktop builds on windows because of this. That seems likely harmful to
> simulator, is that right?

It's indirectly harmful, because presumably some folks use those builds and find/fix problems that also affect the Simulator.  But it isn't directly harmful, because I build B2G Desktop myself for the Simulator; I don't rely on these B2G Desktop builds.
Flags: needinfo?(myk)
Assignee: dtownsend+bugmail → nobody
Flags: needinfo?(poirot.alex)
Flags: needinfo?(ted)
It looks like this fixed itself?  Please reopen if this is still busted.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
It didn't fix itself, this is the bug for the failure, bug 879370 is the bug which stopped doing the builds because nobody was fixing this failure.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bug 879370 indicates bug 903118 may be the right solution here.

Jason, how is this blocking bug 884399 (b2g-on-master)?
Flags: needinfo?(jsmith)
(In reply to Andrew Overholt [:overholt] from comment #162)
> Bug 879370 indicates bug 903118 may be the right solution here.
> 
> Jason, how is this blocking bug 884399 (b2g-on-master)?

It shouldn't be. Let me remove it.
No longer blocks: b2g-central-dogfood
Flags: needinfo?(jsmith)
We cannot reliably build Windows desktop builds off m-c in our automation. Whether this specific bug blocks bug 884399 or not, this issue should be something that's tracked for v1.2 as it is a functional regression from v1.1 IMO. And maybe the blocking status should be moved over to bug 879370, I don't know.
We've not seen a single failure of this since we re-enabled the builds 5 days ago so I'm inclined to call this fixed.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Assignee: nobody → dtownsend+bugmail
Target Milestone: --- → 1.2 FC (16sep)
You need to log in before you can comment on or make changes to this bug.