Closed Bug 876099 Opened 7 years ago Closed 7 years ago

re-enable 3gp support

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24
blocking-b2g leo+
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: gal, Assigned: fabrice)

References

Details

Attachments

(2 files)

Looks like mobile browsers support 3gp, so we won't get around it.
Attachment #754079 - Flags: review?(roc)
a=me to take this for the final IOT build, assuming we can sneak it in
blocking-b2g: --- → tef?
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(In reply to Andreas Gal :gal from comment #2)
> a=me to take this for the final IOT build, assuming we can sneak it in

We need someone to tef+ and get this landed asap then on the 1.01 branch.
Comment on attachment 754079 [details] [diff] [review]
re-enable 3gp for web content (sigh)

Necessary for YT certification. Not holding the release over this, but approved to land.
Attachment #754079 - Flags: approval-mozilla-b2g18+
(In reply to Andreas Gal :gal from comment #4)
> Comment on attachment 754079 [details] [diff] [review]
> re-enable 3gp for web content (sigh)
> 
> Necessary for YT certification. Not holding the release over this, but
> approved to land.

That's not enough to get approval to land. You would need to land this on 1.01, which requires a tef+.
Ok, done.
blocking-b2g: tef? → tef+
This patch doesn't apply on 1.0.1 - we don't do the principal check here at all, so I guess we use something else to prevent 3gp to play in web content?
(In reply to Fabrice Desré [:fabrice] from comment #7)
> This patch doesn't apply on 1.0.1 - we don't do the principal check here at
> all, so I guess we use something else to prevent 3gp to play in web content?

I don't think we stopped it in 1.0.1 so it just works.
If we want to land this, can we do it before our partners create the final build, i.e. we need to land this before 26th May EOB PT.
(In reply to Chris Double (:doublec) from comment #8)
> (In reply to Fabrice Desré [:fabrice] from comment #7)
> > This patch doesn't apply on 1.0.1 - we don't do the principal check here at
> > all, so I guess we use something else to prevent 3gp to play in web content?
> 
> I don't think we stopped it in 1.0.1 so it just works.

Fabrice, in this case, can we land it to v1.0.1?
Flags: needinfo?(fabrice)
(In reply to khu from comment #10)
> (In reply to Chris Double (:doublec) from comment #8)
> > (In reply to Fabrice Desré [:fabrice] from comment #7)
> > > This patch doesn't apply on 1.0.1 - we don't do the principal check here at
> > > all, so I guess we use something else to prevent 3gp to play in web content?
> > 
> > I don't think we stopped it in 1.0.1 so it just works.
> 
> Fabrice, in this case, can we land it to v1.0.1?

Fabrice - Does that mean 3GP should already be working on 1.01? In that case, we don't even need this patch on 1.01, right?
(In reply to Jason Smith [:jsmith] from comment #11)
> Fabrice - Does that mean 3GP should already be working on 1.01? In that
> case, we don't even need this patch on 1.01, right?

Have you confirmed that 3GP video is functional on v1.0.1?
(In reply to Alex Keybl [:akeybl] from comment #12)
> (In reply to Jason Smith [:jsmith] from comment #11)
> > Fabrice - Does that mean 3GP should already be working on 1.01? In that
> > case, we don't even need this patch on 1.01, right?
> 
> Have you confirmed that 3GP video is functional on v1.0.1?

Not yet. Let me put qawanted for someone to take a look.
Keywords: qawanted
blocking-b2g: tef+ → leo+
As noted elsewhere. Note that this patch does *not* help with 3gp support for v1.0.1.

We still do *not* have a plan for how to enable 3gp for v1.0.1 other than in the YouTube app.
(In reply to Alex Keybl [:akeybl] from comment #12)
> (In reply to Jason Smith [:jsmith] from comment #11)
> > Fabrice - Does that mean 3GP should already be working on 1.01? In that
> > case, we don't even need this patch on 1.01, right?
> 
> Have you confirmed that 3GP video is functional on v1.0.1?

3GP is not functional in the browser app in v1.0.1. This is because we don't provide access to the decoding hardware for the browser process(es). And we don't have decoding software of good enough quality to use.

Providing access to the decoding hardware is not an option for v1.0.1 since it will result in background apps holding the decoding hardware and not permitting foreground apps to use it. I.e. it would mean that sometimes you can't watch videos at all.
In terms of this bug, the qawanted request appears to no longer apply. Although we still need to find a 3GP video to test the certified YouTube app with (which happening on a separate email thread).
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #16)
> In terms of this bug, the qawanted request appears to no longer apply.
> Although we still need to find a 3GP video to test the certified YouTube app
> with (which happening on a separate email thread).

I just tested the certified YouTube app. Using the non-HQ setting (ie the HQ button is gray) then 3GP's are served.
Flags: needinfo?(fabrice)
Assignee: nobody → fabrice
https://hg.mozilla.org/mozilla-central/rev/d075c11ea5a0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Blocks: 878183
Blocks: 878987
No longer blocks: 878987
Flags: in-moztrap-
Roc, Chris: Would it make sense to limit support for 3gp to a whitelist of domains? I'd hate for 3gp to become a required part of the web just because YouTube is sitting on 3gp encoded content that they don't want to reencode right now.

Or do you expect that a lot of other mobile websites benefit from 3gp support too?

Or is there no point in fighting over 3gp support given that we're having to support h264 anyway?
(In reply to Jonas Sicking (:sicking) from comment #21)
> Roc, Chris: Would it make sense to limit support for 3gp to a whitelist of
> domains? I'd hate for 3gp to become a required part of the web just because
> YouTube is sitting on 3gp encoded content that they don't want to reencode
> right now.
> 
> Or do you expect that a lot of other mobile websites benefit from 3gp
> support too?
> 
> Or is there no point in fighting over 3gp support given that we're having to
> support h264 anyway?

This feels like a good discussion topic for dev-media.

I did notice during my compatibility testing that the Terra mobile site made heavy use of 3GP media content. So I think there's definite value to investigating 3GP media content usage on the web today.
You need to log in before you can comment on or make changes to this bug.