Delivery reports problem

RESOLVED DUPLICATE of bug 842251

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 842251
5 years ago
5 years ago

People

(Reporter: luigitedone@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Hi, I'm using Firefox OS on my Keon (B2G 1.0.1.0-prerelase). Every time I send and SMS, the delivery report is automatically sent and it is a big waste of money.
(Reporter)

Comment 1

5 years ago
The bug is still present after the upgrade of the Keon to the commit 2013-05-17 07:32:09 460bd2dbe44b5d9d6f497f5944e\b6c6...
(Reporter)

Comment 2

5 years ago
The problem is still present for me. I also try to send some sms with the delivery reports enabled and disabled and I was always charged for 2 sms every time (I receive the delivery report for every sms)

Comment 3

5 years ago
I have two reports from users this week of the same problem with a delivery report. I have recommended that it be reported to geeksphone, since I have no reports of this on other devices. But, thought I should mention that I believe this issue is confirmed for more than one Keon user at this point.
(Reporter)

Comment 4

5 years ago
For me it's fixed right now, but I think it depens also from the telephone carrier.

Comment 5

5 years ago
Hi Luigi Tedone, what is your telephone carrier?
I'm in Italy, and you?
with Vodafone IT e Tim IT i have the same problem.
(Reporter)

Comment 6

5 years ago
Hi Teatrino,
I'm Italian like you :) I tried with TIM IT and H3G IT some weeks ago and I had the problem, but I tried with PosteMobile about 2 weeks ago and all worked fine
Assigning to evhan for assessment
Assignee: nobody → evelyn
Assignee: evelyn → nobody
Steve, I believe you're the best one to comment here.

* Was the behaviour expected in 1.0.1?
* Was it changed in the recent work around reports?
* What is the status in 1.1 and 1.2?

Thanks!
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #8)
> Steve, I believe you're the best one to comment here.
> 
> * Was the behaviour expected in 1.0.1?
We don't have message settings in 1.0.1. If my memory didn't go wrong, default delivery report was enable(Not sure if the defualt report changed to disabled, need gecko devs comfirm). There is no UX for delivery report status in 1.0.1, so user should not be notify that they got the report. This might be ok if carrier didn't charge for the delivery report, but some carrier did and it would be a problem in that situation.
> * Was it changed in the recent work around reports?
There is no big change recently.
> * What is the status in 1.1 and 1.2?
For 1.1, we had message settings with sms delivery report option, For 1.2, we supported delivery mms report. Report will be only requested when delivery report option is enable.

If user using 1.0.1 and our defalut delivry report is enable, it's an expected result to get the delivery report. It's a bad news for user if therir carrier charge for report. Upgrade to v1.1 might be a good option. If user was using v1.1(or later) and they were still charged even the delivery report option is disabled(or using v1.0.1 and default is disabled), it might be a serious bug and definitely need gecko support for futher investigation, thanks.
Flags: needinfo?(vyang)
Flags: needinfo?(schung)
Flags: needinfo?(gene.lian)
Comment #9 is very clear. I don't know what info else to provide.

The only way to solve comment #0 is to provide a patch for V1.0.1 but I don't think we can do it since the code is fixed. In any way, V1.0.1 users have to wait for a update.
Flags: needinfo?(vyang)
Flags: needinfo?(gene.lian)
Yep clearly we won't do anything for v1.0.1.

Therefore I'm going to close this bug. Luigi, if you upgrade in v1.1 and you still see the issue, please reopen this bug!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
bug 842251 (and its dependencies) introduced the configuration of delivery reports in the Settings app.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 842251
(Reporter)

Comment 13

5 years ago
Hello Julien, I upgraded to v1.2 and I switched also my telephone carrier, so I can't test it
Ok, I'm confident it's fixed anyway.

Thanks!
You need to log in before you can comment on or make changes to this bug.