Closed Bug 876474 Opened 9 years ago Closed 9 years ago

about:healthreport doesn't work when build with libxul

Categories

(Firefox Health Report Graveyard :: Client: Desktop, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 831688

People

(Reporter: jhorak, Unassigned)

Details

Attachments

(1 file)

When building xulrunner+firefox combo, about:healthreport shows blank page. Also Preferences/Advanced/Data choices/Enable Firefox Health report doesn't work. 
It's because missing resource://gre/modules/services/healthreport/healthreporter.jsm module in xulrunner.

Attaching patch which's solving this issue.
Attachment #754505 - Flags: review?(mconnor)
This is also a reminder that payload contents need to be tested with xulrunner builds.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 831688
Attachment #754505 - Flags: review?(mconnor) → review?(gps)
(Normally, I'd mark the bug withou a patch as duplicate, but in this case, it has a lot of background)
Comment on attachment 754505 [details] [diff] [review]
Fix for build with libxul v1

Please add patch on the duped bug.
Attachment #754505 - Flags: review?(gps)
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.