[unagi] The latest Unagi kernel doesn't expose the low memory killer trigger notification file

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: gsvelto, Assigned: gsvelto)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
While trying my patch for bug 873284 I discovered that my Unagi doesn't have the /sys/kernel/mm/lowmemkiller/notify_trigger_active pseudo-file anymore. I've extracted the kernel image and the "notify_trigger_active" string doesn't appear anywhere which suggests that we're missing this kernel patch:

https://www.codeaurora.org/gitweb/quic/la/?p=kernel/msm.git;a=commit;h=b3f986cba580b14438b77b42070ebbc77b69d4c4

We rely on that file and the associated mechanism for detecting low memory conditions and sending memory pressure notifications so not having it will skew tests done on the Unagi.
I thought the Unagi never had a working low-memory trigger file.

I don't know why that is.
(Assignee)

Comment 2

5 years ago
(In reply to Justin Lebar [:jlebar] from comment #1)
> I thought the Unagi never had a working low-memory trigger file.
> 
> I don't know why that is.

I hadn't noticed it before as I was using my Unagi for dogfooding and developing on an Otoro. This is kind of nasty because a lot of people have been dogfooding with phones that do not behave as expected when in low-memory conditions. AFAIR functioning low-memory events were quite helpful in keeping alive applications sent to the background.
If you can get low-memory events to work on the Unagi, that's great; I certainly agree that not having them is problematic.  But I'd understood it to be a lost cause.
(Assignee)

Comment 4

5 years ago
I'm building a new kernel with the necessary patch added and I'll test it right away. If it works I'll ask :mwu if it can be pushed to the usual page so that people can update their phones and have this (important IMHO) piece of functionality.
Assignee: nobody → gsvelto
(Assignee)

Comment 5

5 years ago
Created attachment 759790 [details] [diff] [review]
Low memory notification patch

I've rebuilt an Unagi kernel following the instructions available on the intranet wiki with this patch applied. The patch applies cleanly and the resulting kernel boots and this bit of functionality appears to work correctly. However despite my best efforts the resulting zImage file is half the size of the one unagi-kernelupdate6.tar.bz2 and some features don't seem to work (such as the camera). I may be missing something (binary blobs?) so I can't generate a fully working kernel by myself; Michael could you help us out with this one?
Flags: needinfo?(mwu)

Comment 6

5 years ago
Sorry, I don't know much about generating unagi kernels. Unagi isn't supported anymore for many reasons - I recommend getting a new device.
Flags: needinfo?(mwu)
(Assignee)

Comment 7

5 years ago
(In reply to Michael Wu [:mwu] from comment #6)
> Sorry, I don't know much about generating unagi kernels. Unagi isn't
> supported anymore for many reasons - I recommend getting a new device.

Alright, I have other devices fortunately so it's no big deal. I just had hopes in a quick fix since there's still a bunch around. I also wasn't aware that it's not a supported device anymore but since it's unsupported I guess this should be WONTFIX'd.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 8

5 years ago
It's fine for a lot of gaia dev, but it's not worth chasing unagi specific bugs.
Mike, I'm getting a lot of OOM crash reports from people using Unagis.  I'm afraid that this is making us look worse than we actually are, because we don't have our usual low-memory notifications.

If we're not going to fix this bug, I don't want to waste time on OOM crashes that only manifest on Unagi.  Do we have an official-looking document that I can point to that says that we don't care about Unagi?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 842205
You need to log in before you can comment on or make changes to this bug.