autocomplete is too greedy

VERIFIED FIXED in mozilla0.9.4

Status

SeaMonkey
Location Bar
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: bbaetz, Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla0.9.4

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The old autocomplete had the behaviour where 'well-known' url fragments
(http://, http://www, and so on) didn't trigger the drop down.

This appears not to happen any more (unfortunately, IMO), but http://www.f still
appears to be cutting off the http://www. and autocompleting against f.

To reproduce:

1. Using the urlbar, go to ftp://ftp.mozilla.org/
2. Using the urlbar, type http://www.f

Actual results: all file and ftp urls I've ever visited are offered as possible
completions
Expected results: Only sites actually beginning with what I typed are in the
dropdown

Note that http://f will also trigger this, and that http://www.b will try to
autocomplete to http://bonsai.mozilla.org, and so on.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

17 years ago
*** Bug 78404 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

17 years ago
Created attachment 44029 [details] [diff] [review]
patch to fix
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.4

Updated

17 years ago
Keywords: mozilla0.9.4, mozilla1.0
(Assignee)

Comment 3

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
yup. VERIFIED Fixed with 20010907 builds
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.