Closed Bug 876788 Opened 7 years ago Closed 7 years ago

Sync bar can become disabled after frequently syncing and though synchronization completes there is no progress indicator

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: jsmith, Assigned: jlal)

References

Details

(Keywords: regression, Whiteboard: [LeoVB+])

Attachments

(1 file)

Build: B2G 18 5/28
Device: Unagi

STR

1. Import a google calendar with events with alarms
2. Change one of the alarms on the server to a different unit type
** Example: 2 minutes --> 2 days
3. Sync the calendar

Expected

The calendar should sync to show the update to that event to have the updated alarm amount.

Actual

The calendar fails to sync with no progress bar shown. Further sync requests also fail.

Error Console:

05-28 13:18:03.812: E/GeckoConsole(617): Content JS LOG at app://calendar.gaiamobile.org/gaia_build_defer_index.js:664 in anonymous: [ caldav worker ] Could not sync:  /caldav/v2/t6efa1v22cnv6gm57757epuve8%40group.calendar.google.com/events/ ( handleResponse@app://calendar.gaiamobile.org/js/service/caldav.js:777 )
05-28 13:18:03.852: I/Gecko(109): ###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE3
I think this is a symptom of this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=867797
Can you reproduce with 867797 landed?
Keywords: qawanted
QA Contact: jsmith
Unable to repro on 

Leo Build ID: 20130610070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ce3b99781d182ad550a325206990c249b0dbcf0e
Platform Version: 18.0

and on 

Unagi Build ID: 20130611074722
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia: 8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec
Platform Version: 18.0

and on

Unagi Build ID: 20130612030712
Gecko: http://hg.mozilla.org/mozilla-central/rev/cc35f8929768
Gaia: 5db84b067d58b4825d4900cb66a0d10e0522a831
Platform Version: 24.0a1

Syncing email after changing event on server shows correctly on device.
Keywords: qawanted
The testing done on comment 3 is incorrect. You need to change the alarm unit type when testing this. This technically should still be reproducible on b2g18, given that the patch in question hasn't landed on b2g18 yet.
Keywords: qawanted
I was able to reproduce this issue after changing the reminder time from 30 min to 2 days. Now none of the calendar events I create on the server sync to the device. Progress bar is not displaying either. 

Unagi Build ID: 20130611074722
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia: 8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec
Platform Version: 18.0

There was a merge conflict on bug 867797. Will test this again after the patch gets uplifted.
Not able to reproduce on today's unagi build:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/c3a5f0dbb9c6
Gaia   ba4c3763514dbb9fd1dd886b4b6f3bff50bad264
BuildID 20130614115117
Version 18.0

->First added the google calendar account in which there were 2 event already created.
->Changed the alarm type from 30 mins to 1 day. and did a sync. Progress bar appeared and the sync was done.
Did it for two events and it worked fine.


Note: There seem to no 2 days for the reminder time. There maximum time is 1 day.
The patch on bug 867797 still hasn't landed on b2g18, so the testing done on comment 6 still isn't valid. We know this is possible to reproduce, but it doesn't always happen, but it's frequent enough that you'll hit it.
Not seeing this reproduce with the patches recently landed on b2g18.
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Actually, I was wrong. This is still reproducible.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
After a few attempts, I came across an incident where the event took about 1 minute to sync to the calendar. From then on, I have not been seeing the progress bar when syncing, the loading icon in the status bar is displaying tho and the events are syncing for me. 

Unagi Build ID: 20130618070211
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a199b1109860
Gaia: 3e9090894daaa1c7f894a1dcc1026b21f889eadc
Platform Version: 18.0
(In reply to Angela Hubenya from comment #10)
> After a few attempts, I came across an incident where the event took about 1
> minute to sync to the calendar. From then on, I have not been seeing the
> progress bar when syncing, the loading icon in the status bar is displaying
> tho and the events are syncing for me. 
> 
> Unagi Build ID: 20130618070211
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a199b1109860
> Gaia: 3e9090894daaa1c7f894a1dcc1026b21f889eadc
> Platform Version: 18.0

I've seen something similar to this. So maybe we are syncing, but since we lost the progress bar and only show network activity, the user would think the updates would be available, when in fact, they aren't.
I'm also pretty sure this is a regression on 1.1. I don't recall ever seeing this behavior on 1.01.
Keywords: regression
Over to Dylan to get this assigned.
Assignee: nobody → doliver
I suspect this is a case where we hide the bar prematurely. 
Renaming the bug to reflect severity.
Summary: Switching an imported google calendar event to a different alarm unit type will cause that google calendar to fail to sync forever → Sync bar can become disabled after frequently syncing and though synchronization completes there is no progress indicator
Assignee: doliver → gaye
Priority: -- → P1
Target Milestone: 1.1 QE3 (26jun) → 1.1 QE4 (15jul)
needinfo gaye here to help understand how close we are to a low risk resolution here.Also the dependent bug 889396 does not seem to be reproducible on 1.1, so is the dependency marked correctly here ?
Flags: needinfo?(gaye)
Bhavana - I'm working on this today. Last time I took a look there were issues in Gaia that were keeping me from working on this.
Flags: needinfo?(gaye)
Gareth mentions he is having trouble reproducing this now. I'm going to investigate to see if I can get better STR.
Keywords: qawanted
Hey Jason -- any luck finding a good repro?
Flags: needinfo?(jsmith)
Will reevaluate based upon reproducibility.
blocking-b2g: leo+ → leo?
blocking-b2g: leo? → -
(In reply to gaye from comment #18)
> Hey Jason -- any luck finding a good repro?

I was able to reproduce this immediately upon trying to import by gmail account. So it's definitely still reproducible.

Note that this was after using the offline calendar for a while.
Flags: needinfo?(jsmith)
Keywords: qawanted
Another option we could try here is that if you can me a custom Gaia I can build off with a bunch of debug logs enabled, then I can retest this with the debug logs present to get you more information.
Really busy at the moment, but if someone else get try to get better STR here, that would be really helpful.
Keywords: steps-wanted
QA Contact: jsmith
I am able to repro using the following steps.

1. Open the Calendar app
2. Import a Gmail Calendar
3. After the calendar is sync, manually sync the calendar again
4. Make a change to the time of an event on the Computer
5. Manually sync the calendar

Build ID: 20130718070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/7f6f4bc1a621
Gaia: f1d2e3fd806dc55f167c72ac8ef7a3b6baed915e
RIL Version: 01.01.00.019.164
Gareth - Can you try to see if you can reproduce using the STR in comment 23?
Flags: needinfo?(gaye)
Keywords: steps-wanted
(In reply to Jason Smith [:jsmith] from comment #24)
> Gareth - Can you try to see if you can reproduce using the STR in comment 23?

Talked with gaye and lightsofapollo in IRC - James said he'll work on this now. I showed the bug to him in person as well.
Flags: needinfo?(gaye)
Assignee: gaye → jlal
Attachment #779894 - Flags: review?(gaye)
Attachment #779894 - Flags: review?(gaye) → review+
We should get this on v1-train asap
in master: https://github.com/mozilla-b2g/gaia/commit/7d87257a0912599bb4fed88510db26024e499ad9
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
(In reply to Alex Keybl [:akeybl] from comment #19)
> Will reevaluate based upon reproducibility.

Figured out the STR and got a fix -- approving for leo+.
blocking-b2g: - → leo+
Keywords: verifyme
QA Contact: jsmith
Uplifted 7d87257a0912599bb4fed88510db26024e499ad9 to:
v1-train: aad8dd405e3d2e60bdafe80a0125d4cc910a2c48
Issue is verified as fixed on build: 20130724070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/91fa9bf5e638
Gaia: a64f37c3327e4cf2105a16eedaf68727bb2adbde
Platform Version: 18.1

Bar continues to display when sync'ing and no longer disappears.
v1.1.0hd: aad8dd405e3d2e60bdafe80a0125d4cc910a2c48
Whiteboard: [LeoVB+]
You need to log in before you can comment on or make changes to this bug.