canPlayType('audio/mpeg; codecs="mp3"') returns empty string (but can play mp3)

RESOLVED DUPLICATE of bug 838331

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 838331
4 years ago
4 years ago

People

(Reporter: scootergrisen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Trying to use Javascript to test if the browser supports MP3 audio.


Actual results:

canPlayType('audio/mpeg; codecs="mp3"') returns emptry string which is suppose to mean that the browser can't play MP3, but the browser can in fact play it.


Expected results:

canPlayType('audio/mpeg; codecs="mp3"') should return "probably" or "maybe" to indicate that the browser can play it.

canPlayType('audio/mpeg') returns "maybe".

I'm using Firefox Mobile 18.0 on Boot2Gecko 1.0.1.0-prerelease.
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)

Comment 1

4 years ago
On the Gonk platform, we didn't put mp3 as a codec into codec list for checking. I am not sure this is necessary to do this.

Hi Paul,

May I know this is mandatory or not? Very Thanks.
Flags: needinfo?(paul)
Dup of bug 838331? Or are there any b2g specific things?

Comment 3

4 years ago
Yes, it should be the same issue but just report on different platform.

Hi scootergrisen,

Please move to that bug for following discussion. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(paul)
Resolution: --- → DUPLICATE
Duplicate of bug: 838331
You need to log in before you can comment on or make changes to this bug.