bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Buri][IOT][TRANSLATION] incorrect translation when having duplicate contact on phone and try to send SMS

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: kaze)

Tracking

({late-l10n})

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #460175 +++
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.111
 Firefox os  v1.0.1
 Mozilla build ID:20130518070208
 
 DEFECT DESCRIPTION:
 
 Incorrect translation when having a duplicate contact and try to send sms to it
 
  REPRODUCING PROCEDURES:
 
  1. Turn the DuT on with a SIM card.
     2. Select English as default language.
     3. Add two contacts in DUT native addressbook with same MSISDN (same number, same identifier) called, for example: ContactX.
     4. Exchange calls and messages with this MSISDN.
     5. Check Call History and Messages Thread.
     6. Select Spanish as default language.    
     7. Check Call History and Messages Thread.
 
  EXPECTED BEHAVIOUR:
 
 I guess in English shall be “ContactX or 1 other” in both cases; in Spanish “ContactX u otro”
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:high
 
  REPRODUCING RATE: 100 %
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #460175 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

5 years ago
blocking-b2g: --- → tef?

Comment 1

5 years ago
Checked the current behavior:

It will display "ContactX or 1 other" for all languages.
No translation for this string "or 1 other"

Comment 2

5 years ago
Created attachment 755756 [details]
call log show

Comment 3

5 years ago
Created attachment 755757 [details]
SMS show
This is not a blocker for TEF for 1.0.1
Whiteboard: [tef-triage]
triage with tef: per comment 4, not block for v1.0.1, leo?
blocking-b2g: tef? → leo?
(Reporter)

Comment 6

5 years ago
Comment from Mozilla:This is not a blocker for TEF for 1.0.1

Updated

5 years ago
Whiteboard: [tef-triage]
 sync-1@bugzilla.tld :

As per your your screenshots and description they don't seem to go along with one another .The problem as we understand is there is no translation for string "or 1 other" but the screenshot's do show the translation.Can you please clarify ?
(Reporter)

Comment 8

5 years ago
Comment from Mozilla: sync-1@bugzilla.tld :
 
 As per your your screenshots and description they don't seem to go along with one another .The problem as we understand is there is no translation for string "or 1 other" but the screenshot's do show the translation.Can you please clarify ?

Comment 9

5 years ago
Dears,

I think the call log and SMS shold keep the same label, for example in English shall be “ContactX or 1 other” in both cases; in Spanish “ContactX u otro”.

Updated

5 years ago
Assignee: nobody → etienne
blocking-b2g: leo? → leo+
Keywords: late-l10n
I'm not actively working on this, up for grab.
Assignee: etienne → nobody
Over to David to reassign. Since this is late-l10n, throwing into the QE3 milestone to ensure we resolve with time to localize.
Assignee: nobody → dscravaglieri
Target Milestone: --- → 1.1 QE3 (24jun)
Assignee: dscravaglieri → kaze
(Assignee)

Comment 12

5 years ago
Note: in SMS, “ContactX or 1 other” is now displayed as “ContactX (+1)”, see bug 873477.
However, this is not consistent with the Call Log, so let’s apply the same logic to the Dialer.
(Assignee)

Comment 13

5 years ago
In the Dialer, the “ContactX or 1 other” string has been removed from the JS code by bug 865079 (but left in the locale data), and this decision has been validated by UX.

I think we should just:
 • remove the now unused strings in the dialer locales
 • uplift the patches for bugs 865079 and 873477 to v1-train
(Assignee)

Updated

5 years ago
Depends on: 865079
(Assignee)

Comment 15

5 years ago
jhford: commit e6666a2 hasn’t been pushed to v1.1.0hd
(In reply to Fabien Cazenave [:kaze] from comment #15)
> jhford: commit e6666a2 hasn’t been pushed to v1.1.0hd

$ git branch --contains e6666a2
  v1-train
* v1.1.0hd

Setting status flags for v1-train and v1.1.0hd
status-b2g18: --- → fixed
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.