Closed Bug 877070 Opened 7 years ago Closed 7 years ago

[Dialer]Dial the last outgoing call instead of doing last record of call log when doing BT redial

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86_64
Linux
defect
Not set
blocker

Tracking

(blocking-b2g:tef+, firefox24 wontfix, b2g18 wontfix, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

RESOLVED FIXED
1.0.1 IOT3 (3jun)
blocking-b2g tef+
Tracking Status
firefox24 --- wontfix
b2g18 --- wontfix
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: shawnjohnjr, Assigned: rudyl)

References

Details

Attachments

(1 file)

During BQB certification, lab reports we need to do last "outgoing" call, instead of the last record of call log.
I'm not sure if it is possible using multiple keys (outgoing, timestamp) in the cursor. If no, maybe we need to store the latest outgoing call in async storage.
Assignee: nobody → rlu
In the worst case, it needs to iterate all of the calls. Or we simply store the last outgoing calls?
blocking-b2g: --- → tef?
Component: Bluetooth → Gaia::Dialer
Severity: normal → blocker
Does it block BT certification?
Flags: needinfo?(shuang)
Whiteboard: [tef-triage]
Comment on attachment 755288 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10070

[Root Cause]
Dialer app would always find the last number for BT redial not matter it is a incoming or outgoing call.

[Solution]
Iterate the recent call DB (backwards), and find the last outgoing call number.

Hi Etienne,

Could you please review this simple patch?

I think what Arthur mentioned in Comment 3 makes sense, but should be a corner case. This patch should be simpler and with lower risk.

Thank you.
Attachment #755288 - Flags: review?(etienne)
Hi David, we got request from partner, lab requests to change this behavior.
Flags: needinfo?(shuang)
blocking-b2g: tef? → tef+
Whiteboard: [tef-triage]
batch update on tef+ milestones. partner to make a final on 6/3 Asia time. TEF+ needs to be resolved by 6/3 to be in the final build. thanks
Target Milestone: --- → 1.0.1 IOT3 (3jun)
Comment on attachment 755288 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10070

My comments are on github.

Please flag me for review again as soon as they are fixed.
We also need to file a a follow up bug for master and v1-train (it will be a completely different patch because of the call log refactoring).
Attachment #755288 - Flags: review?(etienne)
Comment on attachment 755288 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10070

Hi Etienne,

Just update the pull request to address your comment.
Please help review it again.

Thanks.
Attachment #755288 - Flags: review?(etienne)
Comment on attachment 755288 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10070

r=me

Please squash before landing.

Thanks!
Attachment #755288 - Flags: review?(etienne) → review+
Etienne,

Thanks for the review.

Merged to Gaia v1.0.1,
f13d8be2ff848bae3d72cd83a69abea5e3572311

Note: Gaia master does not have the related changes yet.
As Comment 8 suggested, might need to handle this with another bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Rudy Lu [:rudyl] from comment #11)
> Etienne,
> 
> Thanks for the review.
> 
> Merged to Gaia v1.0.1,
> f13d8be2ff848bae3d72cd83a69abea5e3572311
> 
> Note: Gaia master does not have the related changes yet.
> As Comment 8 suggested, might need to handle this with another bug.

Yes, please open the follow up bug right away (and cc me) before it slips.
Bug 878184 has been created to track this work for Gaia v1-train and master as suggested with Comment 12.
Thanks.
No longer blocks: 878184
You need to log in before you can comment on or make changes to this bug.