Closed Bug 877077 Opened 7 years ago Closed 7 years ago

[Dialer] In multicall state, when disconnecting call, wrong information is shown in call screen.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 876335
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gaia, Assigned: arthurcc)

Details

Attachments

(2 files)

1. Title : In multicall state, when disconnect one call, wrong information is shown in call screen.
2. Precondition : Save one contact
3. Tester's Action : Receive call that didn't save call >> Receive second call that saved call >> Disconnect second call
4. Detailed Symptom : Wrong information is shown
5. Expected : Wrong information isn't shown
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train : Reproduce
8. Gaia Revision : a503d9a1d0a588f3689243c1ddc0f016ede51b9d
9. Gecko Revision : a79f866b03fe1dd5107a83974fac43c2036a8bc8
10 Personal email id : promise09th@gmail.com
I change Tester's action

3. Tester's Action : Receive call that isn't saved in contact >> Receive second call that is saved in contact >> Disconnect second call
blocking-b2g: --- → leo+
Target Milestone: --- → 1.1 QE3
Assignee: nobody → arthur.chen
At the time when the HandledCall object of the second incoming call is initializing, CallScreen.activeCall (the logic of it is also incorrect) returns the node of the first call, which leads to the additional information of the second call being updated to the node of the first call. Maybe we should initialize the HandledCall object after the call becomes connected. Another option would be pass the node that needs to be updated when calling to KeypadManager.updateAdditionalContactInfo.
Etienne, could you help review the patch? Explanation to the patch please refer to github. Thanks!
Attachment #760327 - Flags: review?(etienne)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 876335
Comment on attachment 760327 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/10290

Hey Arthur,

Your patch is getting there, but like I said on bug 876335, the handledCall should own its DOM.

We can add a method on the handledCall, but I don't want to tweak the handledCall DOM from the KeypadManager.
Attachment #760327 - Flags: review?(etienne)
You need to log in before you can comment on or make changes to this bug.