Last Comment Bug 877135 - Remove mozLoadFrom
: Remove mozLoadFrom
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla24
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 872748 879170
  Show dependency treegraph
 
Reported: 2013-05-29 05:12 PDT by Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
Modified: 2013-09-04 05:28 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (10.92 KB, patch)
2013-06-03 20:04 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
cajbir.bugzilla: review+
Details | Diff | Review
remove leftover test (1.50 KB, patch)
2013-08-25 22:40 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
cajbir.bugzilla: review+
Details | Diff | Review

Description Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2013-05-29 05:12:56 PDT
It's non-standard, hardly used at all, and does nothing that "video.src = video2.currentSrc" doesn't do. We should remove it. This would also mean we can remove the test, which is intermittently failing.

http://code.google.com/p/reply-manager/ is the only thing I can find with Google that would potentially break.
Comment 1 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2013-05-29 05:13:46 PDT
Also pageInfo.js needs to be modified in mozilla-central.
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2013-06-03 20:04:19 PDT
Created attachment 757773 [details] [diff] [review]
fix
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2013-06-03 20:31:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/15b8156f48ef
Comment 4 Ed Morley [:emorley] 2013-06-04 07:17:48 PDT
https://hg.mozilla.org/mozilla-central/rev/15b8156f48ef
Comment 6 Frank Wein [:mcsmurf] 2013-08-15 15:37:25 PDT
Should the test at http://mxr.mozilla.org/comm-central/source/mozilla/content/html/content/test/test_mozLoadFrom.html?force=1 also get removed? That test tests mozLoadFrom looks like (but does not fail atm?).
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2013-08-25 22:40:06 PDT
Created attachment 795271 [details] [diff] [review]
remove leftover test
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2013-09-03 21:45:09 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/77f91c65d162
Comment 9 Ed Morley [:emorley] 2013-09-04 05:28:47 PDT
https://hg.mozilla.org/mozilla-central/rev/77f91c65d162

Note You need to log in before you can comment on or make changes to this bug.