Last Comment Bug 877409 - Clean up obsolete GTK code
: Clean up obsolete GTK code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla24
Assigned To: Timothy Arceri
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 14:41 PDT by Timothy Arceri
Modified: 2013-05-31 13:18 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove old gtk check versions (8.95 KB, patch)
2013-05-29 14:47 PDT, Timothy Arceri
karlt: review+
ryanvm: checkin+
Details | Diff | Splinter Review
Replace old calls (1.37 KB, patch)
2013-05-29 23:57 PDT, Timothy Arceri
karlt: review+
ryanvm: checkin+
Details | Diff | Splinter Review

Description Timothy Arceri 2013-05-29 14:41:56 PDT
This bug is for two things:

1. To remove old GTK_CHECK_VERSION/gtk_check_version for versions of GTK already covered by the minimum GTK build requirement 2.10.

2. To remove depreciated GDK_ROOT_PARENT()
Comment 1 Timothy Arceri 2013-05-29 14:47:47 PDT
Created attachment 755616 [details] [diff] [review]
Remove old gtk check versions

Patch to remove old GTK_CHECK_VERSION/gtk_check_version for versions of GTK already covered by the minimum GTK build requirement 2.10.
Comment 2 Timothy Arceri 2013-05-29 23:57:34 PDT
Created attachment 755807 [details] [diff] [review]
Replace old calls

Ok it turns out the remaining GDK_ROOT_PARENT() calls are inside a #if 0 in ./widget/gtk2/nsWindow.cpp

I have provided a patch to update this anyway. But should this code just be removed or is it still useful in some way?
Comment 3 Ryan VanderMeulen [:RyanVM] 2013-05-30 05:13:03 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/06c126ab69d3
Comment 4 Ryan VanderMeulen [:RyanVM] 2013-05-30 09:02:13 PDT
https://hg.mozilla.org/mozilla-central/rev/06c126ab69d3
Comment 5 Karl Tomlinson (back Dec 13 :karlt) 2013-05-30 16:54:15 PDT
Comment on attachment 755807 [details] [diff] [review]
Replace old calls

(In reply to Timothy Arceri from comment #2)
> But should this code just be removed or is it still useful in some way?

I don't mind.  Looks like it is debugging code that might still work, but I haven't used it.  It won't work with GTK3.  If you'd like to remove the paint flashing code, I'd review it.
Comment 6 Timothy Arceri 2013-05-31 03:14:16 PDT
Comment on attachment 755807 [details] [diff] [review]
Replace old calls

I'll just leave it alone for now.
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-05-31 08:50:45 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f73e297ed889
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-05-31 13:18:30 PDT
https://hg.mozilla.org/mozilla-central/rev/f73e297ed889

Note You need to log in before you can comment on or make changes to this bug.