If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[MMS] MMS proxy port is not set by default in the APN settings

RESOLVED DUPLICATE of bug 937894

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 937894
4 years ago
4 years ago

People

(Reporter: Anshul, Assigned: bevis)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Put an ATT card and then go to settings -> Cellula & Data -> Message Settings and see that MMS proxy port for ATT card (80) is not selected by default. Without this port the MMS can not be downloaded by WAP.
Ansul, could you provide the MCC and MNC codes stored in that SIM?
(Reporter)

Comment 2

4 years ago
MCC = 310, MNC = 410
Thanks Anshul, the APN settings we have in our database for that pair of codes is:

{"carrier":"Cingular 410","apn":"wap.cingular","user":"WAP@CINGULARGPRS.COM","password":"CINGULAR1","server":"cingulargprs.com","mmsc":"http://mmsc.cingular.com/","mmsproxy":"wireless.cingular.com","type":["default","supl","mms"]}

So it seems the port is also missing in the AOSP APN database (see [1])

What we can do here is to contribute to the AOSP APN database and wait for that change to be added. It usually takes some time. To be honest I'm still waiting a change to be reviewed more than a month :(.

Is that a blocker actually?

[1] https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/apn/apns_conf.xml#L3914-L3924
(Reporter)

Comment 4

4 years ago
Jose, no this is not a blocker.
blocking-b2g: leo? → ---
Duplicate of this bug: 890131
Apologies, typo'd when duping 890131 to another bug.
Component: Gaia::SMS → RIL
It seems the current solution is to fix the APN database, which is managed and included in the Gaia repository. Reassigning this bug to the Gaia::SMS component. Please correct me if I'm wrong. Thanks!
Component: RIL → Gaia::SMS
Wait! Gecko should already fallback this to 80 [1].

[1] http://mxr.mozilla.org/mozilla-central/source/dom/mobilemessage/src/gonk/MmsService.js#180
Component: Gaia::SMS → RIL
Hi Bevis, do you have bandwidth to check this?
(Assignee)

Comment 10

4 years ago
Sure! It's supposed to be fixed in bug#937894.
I'll try to figure out what we behave now in mozilla-central.
(Assignee)

Updated

4 years ago
Assignee: nobody → btseng
(Assignee)

Comment 11

4 years ago
After testing with current mozilla-central build, the port will be fallback to 80 if it's not set in the apn settings.

The fix in bug#937894 is workable.

Mark as duplicated to bug#937894.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937894
You need to log in before you can comment on or make changes to this bug.